summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHernan Grecco <hgrecco@gmail.com>2023-05-01 10:46:04 -0300
committerHernan Grecco <hgrecco@gmail.com>2023-05-01 11:14:10 -0300
commita814d1bc4a2e1b0786ca1e56e0f9bf7e363434b4 (patch)
treee2fc707fc75cf711b834faecbaeab510338c10a0
parentf536abcfbb823ba55a35922da94b26ecc5f6d7b8 (diff)
downloadpint-a814d1bc4a2e1b0786ca1e56e0f9bf7e363434b4.tar.gz
Tooling: remove bors and remove zest-releaser
-rw-r--r--.github/workflows/ci.yml10
-rw-r--r--.github/workflows/publish.yml27
-rw-r--r--bors.toml8
-rw-r--r--docs/dev/contributing.rst2
-rw-r--r--pyproject.toml2
-rw-r--r--version.py6
6 files changed, 28 insertions, 27 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index e73a8c8..7dd55db 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -226,13 +226,3 @@ jobs:
# run: |
# pip install coveralls "requests<2.29"
# coveralls --finish
-
- # Dummy task to summarize all. See https://github.com/bors-ng/bors-ng/issues/1300
- # ci-success:
- # name: ci
- # if: ${{ success() }}
- # needs: test-linux
- # runs-on: ubuntu-latest
- # steps:
- # - name: CI succeeded
- # run: exit 0
diff --git a/.github/workflows/publish.yml b/.github/workflows/publish.yml
new file mode 100644
index 0000000..3cf9f79
--- /dev/null
+++ b/.github/workflows/publish.yml
@@ -0,0 +1,27 @@
+name: Build and publish to PyPI
+
+on:
+ push:
+ tags:
+ - '*'
+
+jobs:
+ publish:
+ runs-on: ubuntu-latest
+ steps:
+ - uses: actions/checkout@v3
+
+ - uses: actions/setup-python@v4
+ with:
+ python-version: '3.x'
+
+ - name: Install dependencies
+ run: python -m pip install build
+
+ - name: Build package
+ run: python -m build
+
+ - name: Publish to PyPI
+ uses: pypa/gh-action-pypi-publish@release/v1
+ with:
+ password: ${{ secrets.PYPI_API_TOKEN }}
diff --git a/bors.toml b/bors.toml
deleted file mode 100644
index 4e9e7be..0000000
--- a/bors.toml
+++ /dev/null
@@ -1,8 +0,0 @@
-status = [
- "ci",
- "docbuild",
- "lint"
-]
-delete_merged_branches = true
-timeout_sec = 10800
-block_labels = [ "do-not-merge-yet" ]
diff --git a/docs/dev/contributing.rst b/docs/dev/contributing.rst
index c63381b..e70a375 100644
--- a/docs/dev/contributing.rst
+++ b/docs/dev/contributing.rst
@@ -9,7 +9,6 @@ Pint uses (and thanks):
- `github actions`_ to test all commits and PRs.
- coveralls_ to monitor coverage test coverage
- readthedocs_ to host the documentation.
-- `bors-ng`_ as a merge bot and therefore every PR is tested before merging.
- black_, isort_ and flake8_ as code linters and pre-commit_ to enforce them.
- pytest_ to write tests
- sphinx_ to write docs.
@@ -133,7 +132,6 @@ features that work best as an extension package versus direct inclusion in Pint
.. _github: http://github.com/hgrecco/pint
.. _`issue tracker`: https://github.com/hgrecco/pint/issues
-.. _`bors-ng`: https://github.com/bors-ng/bors-ng
.. _`github docs`: https://help.github.com/articles/closing-issues-via-commit-messages/
.. _`github actions`: https://docs.github.com/en/actions
.. _coveralls: https://coveralls.io/
diff --git a/pyproject.toml b/pyproject.toml
index e231412..bbcfbdf 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -27,7 +27,7 @@ classifiers = [
"Programming Language :: Python :: 3.11"
]
requires-python = ">=3.9"
-dynamic = ["version"]
+dynamic = ["version"] # Version is taken from git tags using setuptools_scm
[tool.setuptools.package-data]
pint = [
diff --git a/version.py b/version.py
deleted file mode 100644
index c9114dd..0000000
--- a/version.py
+++ /dev/null
@@ -1,6 +0,0 @@
-# This is just for zest.releaser. Do not touch
-# flake8: noqa
-
-# fmt: off
-__version__ = '0.21.dev0'
-# fmt: on