summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Edmund Crosley <timothy.crosley@gmail.com>2014-02-24 12:33:16 -0500
committerTimothy Edmund Crosley <timothy.crosley@gmail.com>2014-02-24 12:33:16 -0500
commit0288fb8ac473b5e2183e18556459eef91d864ce9 (patch)
tree51f2baf3ceefd811871fb2857cdf8bde2eb06256
parent38686ef1dc5fdae79727c0aca39996a9ee9cfd98 (diff)
parent3d1cf9fd685ad476e631d2bca76024bc9447be5d (diff)
downloadpies-0288fb8ac473b5e2183e18556459eef91d864ce9.tar.gz
Merge pull request #25 from msabramo/travis
.travis.yml: Run py.test, install pies2overrides for py2
-rw-r--r--.travis.yml11
1 files changed, 10 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 1e66aee..1c61464 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,7 +1,16 @@
language: python
python:
+ - "pypy"
- "2.6"
- "2.7"
- "3.2"
- "3.3"
-script: python setup.py test \ No newline at end of file
+install:
+ - if [[ $TRAVIS_PYTHON_VERSION == '2.6' ||
+ $TRAVIS_PYTHON_VERSION == '2.7' ||
+ $TRAVIS_PYTHON_VERSION == 'pypy' ]]; then
+ pip install ./pies2overrides;
+ fi
+script:
+ - pip install pytest
+ - py.test