summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2015-07-12 00:34:45 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2015-07-12 00:34:45 -0700
commit173be089008b89c3dfee74420973f98f6e8b0ef3 (patch)
tree4f768358ea29502a217186ccf219b354ed41cf7a
parente3f9fdf008f1c1f803c33ac93cefac0e01f6fdfd (diff)
parentb713d996484fac9d2a4a2e85bee3073a98cabacf (diff)
downloadpies-master.tar.gz
Merge branch 'release/2.6.7'2.6.7master
-rw-r--r--README.md2
-rw-r--r--pies/__init__.py2
-rw-r--r--pies2overrides/_thread.py3
-rw-r--r--pies2overrides/setup.py14
-rw-r--r--setup.py15
5 files changed, 9 insertions, 27 deletions
diff --git a/README.md b/README.md
index a1bd99a..57a8d8e 100644
--- a/README.md
+++ b/README.md
@@ -32,7 +32,7 @@ only when absolutely necessary.
How does pies differ from six?
====================
-Pies is significantly smaller and simpler then six because it assumes for
+Pies is significantly smaller and simpler than six because it assumes for
everything possible the developer is using the Python 3 compatible versions included with Python 2.6+,
whereas six tries to maintain compatibility with Python 2.4 -
leading to many more overrides and further into different language territory.
diff --git a/pies/__init__.py b/pies/__init__.py
index d290275..2af14c0 100644
--- a/pies/__init__.py
+++ b/pies/__init__.py
@@ -28,4 +28,4 @@ CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFT
OTHER DEALINGS IN THE SOFTWARE.
"""
-__version__ = "2.6.5"
+__version__ = "2.6.7"
diff --git a/pies2overrides/_thread.py b/pies2overrides/_thread.py
deleted file mode 100644
index 089dd41..0000000
--- a/pies2overrides/_thread.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from __future__ import absolute_import
-
-from _thread import *
diff --git a/pies2overrides/setup.py b/pies2overrides/setup.py
index 8c4d323..6a96e63 100644
--- a/pies2overrides/setup.py
+++ b/pies2overrides/setup.py
@@ -9,20 +9,16 @@ try:
except ImportError:
from distutils.core import setup
-install_requires = ['ipaddress']
-if sys.version_info[0] == 2 and sys.version_info[1] < 7:
- install_requires += ['ordereddict', 'argparse']
-
setup(name='pies2overrides',
- version='2.6.5',
+ version='2.6.7',
description='Defines override classes that should be included with pies only if running on Python2.',
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.6.5.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.6.7.tar.gz?raw=true',
license="MIT",
- install_requires=install_requires,
- requires=install_requires,
+ install_requires=['ipaddress'],
+ requires=['ipaddress'],
extras_require={':python_version=="2.6"': ['ordereddict', 'argparse']},
- py_modules=['configparser', 'builtins', '_thread', 'copyreg', 'queue', 'reprlib', 'socketserver'],
+ py_modules=['configparser', 'builtins', 'copyreg', 'queue', 'reprlib', 'socketserver'],
packages=['html', 'http', 'xmlrpc'])
diff --git a/setup.py b/setup.py
index 6ee2ce1..0c86f20 100644
--- a/setup.py
+++ b/setup.py
@@ -8,15 +8,6 @@ try:
except ImportError:
from distutils.core import setup
-install_requires = []
-if sys.version_info[0] < 3:
- install_requires += ['pies2overrides']
-elif sys.version_info[1] < 2:
- install_requires += ['argparse', 'configparser']
-
-if sys.version_info[0] < 3 or sys.version_info[1] < 4:
- install_requires += ['enum34']
-
try:
import pypandoc
readme = pypandoc.convert('README.md', 'rst')
@@ -24,21 +15,19 @@ except (IOError, ImportError, OSError, RuntimeError):
readme = ''
setup(name='pies',
- version='2.6.5',
+ version='2.6.7',
description='The simplest way to write one program that runs on both Python 2 and Python 3.',
long_description=readme,
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-2.6.5.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-2.6.7.tar.gz?raw=true',
license="MIT",
- install_requires=install_requires,
extras_require={':python_version=="2.6" or python_version=="2.7"': ['pies2overrides', 'enum34'],
':python_version=="3.0" or python_version=="3.1" or '
'python_version=="3.2" or python_version=="3.3"': ['enum34'],
':python_version=="3.0" or python_version=="3.1" or python_version=="3.2"':
['argparse', 'configparser']},
- requires=install_requires,
packages=['pies'],
keywords='Python, Python2, Python3, six, future, refactoring, single-code-base',
classifiers=['Development Status :: 5 - Production/Stable',