summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Quast <contact@jeffquast.com>2015-04-26 16:50:47 -0700
committerJeff Quast <contact@jeffquast.com>2015-04-26 16:50:47 -0700
commit1c6726bbe175c74ddc8eca356f2e7da57763f053 (patch)
tree2a8a39f89d7ec4d834f36af4d413b59e5b327471
parent650328c5aa7e812d7562c82635857315f56668b3 (diff)
downloadpexpect-teamcity-tests-ptyprocess.tar.gz
Do not combine ptyprocess coverage into pexpect'steamcity-tests-ptyprocess
-rwxr-xr-xtools/teamcity-runtests.sh8
1 files changed, 2 insertions, 6 deletions
diff --git a/tools/teamcity-runtests.sh b/tools/teamcity-runtests.sh
index 5e794bc..3c92342 100755
--- a/tools/teamcity-runtests.sh
+++ b/tools/teamcity-runtests.sh
@@ -51,16 +51,12 @@ if [ $ret -ne 0 ]; then
echo "py.test returned exit code ${ret}." >&2
echo "the build should detect and report these failing tests." >&2
fi
-# combine ptyprocess's coverage into pexpect's
-coverage combine
-cp .coverage $here/../.coverage.ptyprocess.${osrel}
-# install ptyprocess,
+# install ptyprocess as a package,
python setup.py install
-# run tests
+# run pexpect tests (now that ptyprocess dependency is fulfilled)
cd $here/..
-pwd
ret=0
py.test \
--cov pexpect --cov $here/../../ptyprocess/ptyprocess \