summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohann C. Rocholl <johann@rocholl.net>2009-10-04 03:29:30 -0700
committerJohann C. Rocholl <johann@rocholl.net>2009-10-04 03:29:30 -0700
commit21022f0a566db0fcdb47b2e5b31ba247b11432d1 (patch)
tree8dcf0be068fbf1c0c4dde1a2b9fc268ff6558999 /Makefile
parentaaca8e794708613b8216f905d8e63a1efa6cdcb2 (diff)
downloadpep8-21022f0a566db0fcdb47b2e5b31ba247b11432d1.tar.gz
Added doctest for Python versions from 2.3 to 3.1.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 11e86f8..05c27b7 100644
--- a/Makefile
+++ b/Makefile
@@ -16,6 +16,12 @@ multitest :
python2.6 pep8.py --testsuite testsuite
python3.0 pep8.py --testsuite testsuite
python3.1 pep8.py --testsuite testsuite
+ python2.3 pep8.py --doctest
+ python2.4 pep8.py --doctest
+ python2.5 pep8.py --doctest
+ python2.6 pep8.py --doctest
+ python3.0 pep8.py --doctest
+ python3.1 pep8.py --doctest
python2.3 pep8.py --repeat --statistics pep8.py
python2.4 pep8.py --repeat --statistics pep8.py
python2.5 pep8.py --repeat --statistics pep8.py