summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2014-03-11 23:52:09 -0400
committerRyan Petrello <lists@ryanpetrello.com>2014-03-18 14:03:06 -0700
commitc047087b72d37f094320e3bdff3fc24a79551ea8 (patch)
tree7ca81a66d3055f53b76f65e48fef383394982fc8 /setup.py
parentb046c1e965e2a37758c5092402a92b46217d58b4 (diff)
downloadpecan-c047087b72d37f094320e3bdff3fc24a79551ea8.tar.gz
Add formal support for pypy.
Fixes bug 1290922 Change-Id: I93f8318bad32800eb384e6a5e09dfc8eae5fed79
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index fa7c87d..e32f5ad 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
import sys
+import platform
from setuptools import setup, find_packages
@@ -60,7 +61,9 @@ if sys.version_info < (2, 7):
if sys.version_info < (3, 0):
# These don't support Python3 yet - don't run their tests
- tests_require += ['Kajiki']
+ if platform.python_implementation() != 'PyPy':
+ # Kajiki is not pypy-compatible
+ tests_require += ['Kajiki']
tests_require += ['Genshi']
else:
# Genshi added Python3 support in 0.7
@@ -96,6 +99,7 @@ setup(
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Internet :: WWW/HTTP :: WSGI',
'Topic :: Software Development :: Libraries :: Application Frameworks'
],