summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2013-03-12 15:45:37 -0400
committerRyan Petrello <lists@ryanpetrello.com>2013-03-13 14:02:16 -0400
commit7b736524f904b113fe8123f079af7c4d6f505814 (patch)
treeb9a1986a28ce0dba9f65810eff8fffcb092872bc /setup.py
parent1bf1debce68d6196cad058b5a19d2c9a04233199 (diff)
downloadpecan-7b736524f904b113fe8123f079af7c4d6f505814.tar.gz
Extract the scaffold-building tests into tox.
A lot of code was being utilized to provide a *much* slower version of what tox already provides. This changes scaffold-building tests to run in tox across Python versions.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 0 insertions, 20 deletions
diff --git a/setup.py b/setup.py
index 46a677d..8db7d6e 100644
--- a/setup.py
+++ b/setup.py
@@ -37,25 +37,6 @@ tests_require = requirements + [
if sys.version_info < (2, 7):
tests_require += ['unittest2']
-
-class test(TestCommand):
-
- user_options = TestCommand.user_options + [(
- 'functional',
- None,
- 'Run all tests (even the really slow functional ones)'
- )]
-
- def initialize_options(self):
- self.functional = None
- return TestCommand.initialize_options(self)
-
- def finalize_options(self):
- if self.functional:
- import pecan
- setattr(pecan, '__run_all_tests__', True)
- return TestCommand.finalize_options(self)
-
#
# call setup
#
@@ -93,7 +74,6 @@ setup(
install_requires=requirements,
tests_require=tests_require,
test_suite='pecan',
- cmdclass={'test': test},
entry_points="""
[pecan.command]
serve = pecan.commands:ServeCommand