summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2013-09-17 17:33:32 -0400
committerRyan Petrello <lists@ryanpetrello.com>2013-09-22 21:14:26 -0400
commit435e5fa34a6a87129f6922c18fa36e26d60e4e7f (patch)
tree08d083d1160e95597c752e645d2200b79a988e48 /setup.py
parent09ea1274589d51104d89d2b325906aa0a36c181a (diff)
downloadpecan-435e5fa34a6a87129f6922c18fa36e26d60e4e7f.tar.gz
Replace simplegeneric with singledispatch (PEP 443).
Closes-Bug: #1226813 Change-Id: I1ba149ac00353460065d4cddbe3ccd8782aaa611
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 12 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index efb3454..2d724f6 100644
--- a/setup.py
+++ b/setup.py
@@ -39,10 +39,21 @@ except:
#
requirements.append('argparse')
+try:
+ from functools import singledispatch # noqa
+except:
+ #
+ # This was introduced in Python 3.4 - the singledispatch package contains
+ # a backported replacement for 2.6 through 3.3
+ #
+ requirements.append('singledispatch')
+
+
tests_require = requirements + [
'virtualenv',
'gunicorn',
- 'mock'
+ 'mock',
+ 'sqlalchemy'
]
if sys.version_info < (2, 7):
tests_require += ['unittest2']