summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2013-04-30 10:47:10 -0400
committerRyan Petrello <lists@ryanpetrello.com>2013-04-30 10:47:10 -0400
commit125495a899f984d7a33d7bacb56f3212314ef995 (patch)
tree69cd880d2b5d3eedb88ae7f7ee4e7ac8aa15fd24 /setup.py
parent98f3c566ee3eb7f9d3b31e9e153dc8cbf3e22dc4 (diff)
downloadpecan-125495a899f984d7a33d7bacb56f3212314ef995.tar.gz
Add Python 3.2+ to list of compatible versions. Add `six`.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 7 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 758774c..423c01f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
import sys
+
from setuptools import setup, find_packages
-from setuptools.command.test import test as TestCommand
version = '0.2.3'
@@ -11,7 +11,8 @@ requirements = [
"WebOb >= 1.2dev", # py3 compat
"simplegeneric >= 0.8", # py3 compat
"Mako >= 0.4.0",
- "WebTest >= 1.3.1" # py3 compat
+ "WebTest >= 1.3.1", # py3 compat
+ "six"
]
try:
@@ -58,8 +59,12 @@ setup(
'Operating System :: Microsoft :: Windows',
'Operating System :: POSIX',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
'Topic :: Internet :: WWW/HTTP :: WSGI',
'Topic :: Software Development :: Libraries :: Application Frameworks'
],