summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2013-01-09 22:00:50 -0500
committerRyan Petrello <lists@ryanpetrello.com>2013-01-09 22:04:06 -0500
commit0bd4be184a6fb241a36a3d0b2af48fe9abdde44a (patch)
tree0cbcc4428bf4ca3f2c2b125ef6d49116ea0c028e /setup.py
parent890f86d98098163d1ea0bc70cb5600ea6b0669d6 (diff)
downloadpecan-0bd4be184a6fb241a36a3d0b2af48fe9abdde44a.tar.gz
Add support for a ``gunicorn_pecan`` console script.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e4356c9..097fc12 100644
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,8 @@ tests_require = requirements + [
'virtualenv',
'Genshi',
'Kajiki',
- 'Jinja'
+ 'Jinja',
+ 'gunicorn'
]
if sys.version_info < (2, 7):
tests_require += ['unittest2']
@@ -102,5 +103,6 @@ setup(
base = pecan.scaffolds:BaseScaffold
[console_scripts]
pecan = pecan.commands:CommandRunner.handle_command_line
+ gunicorn_pecan = pecan.commands.serve:gunicorn_run
"""
)