summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2014-10-14 17:35:45 -0400
committerRyan Petrello <lists@ryanpetrello.com>2014-10-14 17:35:45 -0400
commitc7f241fd6bb8a0b10e02b8b43aaf1810c312cfbf (patch)
treecb148279e270f9ab2abc5129f8321112348e90b5
parent65ce81dee6bb5fbbf8dbe05fa133b2b0643c47f7 (diff)
downloadpecan-c7f241fd6bb8a0b10e02b8b43aaf1810c312cfbf.tar.gz
Version increment.0.8.0
Change-Id: I7edccb6171682585891d9898055fc6b7da54cfaa
-rw-r--r--docs/source/changes.rst11
-rw-r--r--setup.py2
2 files changed, 12 insertions, 1 deletions
diff --git a/docs/source/changes.rst b/docs/source/changes.rst
index 0fa3db9..9c99268 100644
--- a/docs/source/changes.rst
+++ b/docs/source/changes.rst
@@ -1,3 +1,14 @@
+0.8.0
+=====
+ * For HTTP POSTs, map JSON request bodies to controller keyword arguments.
+ * Improve argspec detection and leniency for wrapped controllers.
+ * When path arguments are incorrect for RestController, return HTTP 404, not 400.
+ * When detecting non-content for HTTP 204, properly catch UnicodeDecodeError.
+ * Fix a routing bug for generic subcontrollers.
+ * Fix a bug in generic function handling when context locals are disabled.
+ * Fix a bug that mixes up argument order for generic functions.
+ * Remove `assert` for flow control; it can be optimized away with `python -O`.
+
0.7.0
=====
* Fixed an edge case in RestController routing which should have returned an
diff --git a/setup.py b/setup.py
index a0234ac..9ccfeb8 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@ import platform
from setuptools import setup, find_packages
-version = '0.7.0'
+version = '0.8.0'
#
# determine requirements