summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@ubuntu.com>2020-02-02 11:47:56 +0000
committerGitHub <noreply@github.com>2020-02-02 11:47:56 +0000
commitab257360ccd6d1a5a41e23a2feef7127f31a4d1d (patch)
tree5f95f69e5fad8a543f6ac0c94666cd7685e44582
parent596ec6804b1ad649542da3d8d8fe0cabcf22123f (diff)
downloadpastedeploy-git-ab257360ccd6d1a5a41e23a2feef7127f31a4d1d.tar.gz
Remove pytest-runner integration (#24)
`pytest-runner` describes itself as deprecated in its own package description, referring to https://github.com/pypa/setuptools/issues/1684. Using it in `setup_requires` means that any other package that depends on PasteDeploy has to install `pytest-runner` too, which is fairly heavyweight and unnecessary. (I ran into this when trying to update Launchpad to a less ancient version of PasteDeploy.) This does mean that `python setup.py test` no longer works, but, according to the setuptools issue above, that's deprecated anyway. PasteDeploy already has `tox` configuration that works well.
-rw-r--r--setup.cfg3
-rw-r--r--setup.py2
2 files changed, 0 insertions, 5 deletions
diff --git a/setup.cfg b/setup.cfg
index 3c00092..f15c017 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,2 @@
[wheel]
universal = true
-
-[aliases]
-test = pytest
diff --git a/setup.py b/setup.py
index fd1b5f4..e15e7a7 100644
--- a/setup.py
+++ b/setup.py
@@ -52,8 +52,6 @@ setup(
packages=find_packages(exclude=["tests"]),
include_package_data=True,
zip_safe=False,
- setup_requires=["pytest-runner"],
- tests_require=["pytest"],
extras_require={
"Config": [],
"Paste": ["Paste"],