summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--paste/__init__.py2
-rw-r--r--paste/auth/__init__.py2
-rw-r--r--paste/auth/auth_tkt.py2
-rw-r--r--paste/auth/grantip.py2
-rw-r--r--paste/debug/__init__.py2
-rwxr-xr-xpaste/debug/debugapp.py2
-rwxr-xr-xpaste/debug/doctest_webapp.py2
-rw-r--r--paste/debug/fsdiff.py2
-rw-r--r--paste/evalexception/__init__.py2
-rw-r--r--paste/evalexception/evalcontext.py2
-rw-r--r--paste/evalexception/middleware.py2
-rw-r--r--paste/exceptions/__init__.py2
-rw-r--r--paste/exceptions/collector.py2
-rw-r--r--paste/fileapp.py2
-rw-r--r--paste/gzipper.py2
-rw-r--r--paste/httpexceptions.py2
-rw-r--r--paste/httpheaders.py2
-rwxr-xr-xpaste/httpserver.py2
-rw-r--r--paste/pony.py2
-rw-r--r--paste/printdebug.py2
-rw-r--r--paste/profilemiddleware.py2
-rwxr-xr-xpaste/progress.py2
-rw-r--r--paste/proxy.py2
-rw-r--r--paste/reloader.py2
-rw-r--r--paste/request.py2
-rw-r--r--paste/response.py2
-rw-r--r--paste/transaction.py2
-rw-r--r--paste/translogger.py2
-rw-r--r--paste/util/finddata.py2
-rw-r--r--paste/util/multidict.py2
-rw-r--r--paste/wdg_validate.py2
-rw-r--r--paste/wsgiwrappers.py2
32 files changed, 64 insertions, 0 deletions
diff --git a/paste/__init__.py b/paste/__init__.py
index efc338d..69391f2 100644
--- a/paste/__init__.py
+++ b/paste/__init__.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
try:
import pkg_resources
pkg_resources.declare_namespace('paste')
diff --git a/paste/auth/__init__.py b/paste/auth/__init__.py
index ad914d6..186e2ef 100644
--- a/paste/auth/__init__.py
+++ b/paste/auth/__init__.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""
Package for authentication/identification of requests.
diff --git a/paste/auth/auth_tkt.py b/paste/auth/auth_tkt.py
index e47653a..f61212a 100644
--- a/paste/auth/auth_tkt.py
+++ b/paste/auth/auth_tkt.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
##########################################################################
#
# Copyright (c) 2005 Imaginary Landscape LLC and Contributors.
diff --git a/paste/auth/grantip.py b/paste/auth/grantip.py
index cf6a64c..94b3900 100644
--- a/paste/auth/grantip.py
+++ b/paste/auth/grantip.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""
Grant roles and logins based on IP address.
"""
diff --git a/paste/debug/__init__.py b/paste/debug/__init__.py
index ed5577a..daef7cc 100644
--- a/paste/debug/__init__.py
+++ b/paste/debug/__init__.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""
Package for debugging and development tools
"""
diff --git a/paste/debug/debugapp.py b/paste/debug/debugapp.py
index 15118d3..7db39e9 100755
--- a/paste/debug/debugapp.py
+++ b/paste/debug/debugapp.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# (c) 2005 Clark C. Evans
# This module is part of the Python Paste Project and is released under
# the MIT License: http://www.opensource.org/licenses/mit-license.php
diff --git a/paste/debug/doctest_webapp.py b/paste/debug/doctest_webapp.py
index f1747cd..a0ca130 100755
--- a/paste/debug/doctest_webapp.py
+++ b/paste/debug/doctest_webapp.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
#!/usr/bin/env python2.4
# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
diff --git a/paste/debug/fsdiff.py b/paste/debug/fsdiff.py
index 838aae9..96f2744 100644
--- a/paste/debug/fsdiff.py
+++ b/paste/debug/fsdiff.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""
Module to find differences over time in a filesystem
diff --git a/paste/evalexception/__init__.py b/paste/evalexception/__init__.py
index 5f6dd4f..298d72b 100644
--- a/paste/evalexception/__init__.py
+++ b/paste/evalexception/__init__.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""
An exception handler for interactive debugging
"""
diff --git a/paste/evalexception/evalcontext.py b/paste/evalexception/evalcontext.py
index 5ce311d..dca2a97 100644
--- a/paste/evalexception/evalcontext.py
+++ b/paste/evalexception/evalcontext.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
from cStringIO import StringIO
import traceback
import threading
diff --git a/paste/evalexception/middleware.py b/paste/evalexception/middleware.py
index 3647552..41c5751 100644
--- a/paste/evalexception/middleware.py
+++ b/paste/evalexception/middleware.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""
Exception-catching middleware that allows interactive debugging.
diff --git a/paste/exceptions/__init__.py b/paste/exceptions/__init__.py
index 3996c70..813f855 100644
--- a/paste/exceptions/__init__.py
+++ b/paste/exceptions/__init__.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""
Package for catching exceptions and displaying annotated exception
reports
diff --git a/paste/exceptions/collector.py b/paste/exceptions/collector.py
index 05742e9..2b454e5 100644
--- a/paste/exceptions/collector.py
+++ b/paste/exceptions/collector.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
##############################################################################
#
# Copyright (c) 2001, 2002 Zope Corporation and Contributors.
diff --git a/paste/fileapp.py b/paste/fileapp.py
index 72dbf4e..d14cf26 100644
--- a/paste/fileapp.py
+++ b/paste/fileapp.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# (c) 2005 Ian Bicking, Clark C. Evans and contributors
# This module is part of the Python Paste Project and is released under
# the MIT License: http://www.opensource.org/licenses/mit-license.php
diff --git a/paste/gzipper.py b/paste/gzipper.py
index 3083139..2b01c5c 100644
--- a/paste/gzipper.py
+++ b/paste/gzipper.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
diff --git a/paste/httpexceptions.py b/paste/httpexceptions.py
index 6bddf9b..a4e5074 100644
--- a/paste/httpexceptions.py
+++ b/paste/httpexceptions.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# (c) 2005 Ian Bicking, Clark C. Evans and contributors
# This module is part of the Python Paste Project and is released under
# the MIT License: http://www.opensource.org/licenses/mit-license.php
diff --git a/paste/httpheaders.py b/paste/httpheaders.py
index 0350d66..ea7bd2b 100644
--- a/paste/httpheaders.py
+++ b/paste/httpheaders.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# (c) 2005 Ian Bicking, Clark C. Evans and contributors
# This module is part of the Python Paste Project and is released under
# the MIT License: http://www.opensource.org/licenses/mit-license.php
diff --git a/paste/httpserver.py b/paste/httpserver.py
index 4918acd..7d91056 100755
--- a/paste/httpserver.py
+++ b/paste/httpserver.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# (c) 2005 Clark C. Evans
# This module is part of the Python Paste Project and is released under
# the MIT License: http://www.opensource.org/licenses/mit-license.php
diff --git a/paste/pony.py b/paste/pony.py
index 83268be..a8446d6 100644
--- a/paste/pony.py
+++ b/paste/pony.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""
We have a pony
"""
diff --git a/paste/printdebug.py b/paste/printdebug.py
index 92db940..83f97fe 100644
--- a/paste/printdebug.py
+++ b/paste/printdebug.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# Deprecated 18 Dec 2005
"""
Deprecated -- see ``paste.debug.prints``
diff --git a/paste/profilemiddleware.py b/paste/profilemiddleware.py
index f097921..5f32adf 100644
--- a/paste/profilemiddleware.py
+++ b/paste/profilemiddleware.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# Deprecated 18 Dec 2005
"""
Deprecated -- see ``paste.debug.profile``
diff --git a/paste/progress.py b/paste/progress.py
index be265a4..ca51d18 100755
--- a/paste/progress.py
+++ b/paste/progress.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# (c) 2005 Clark C. Evans
# This module is part of the Python Paste Project and is released under
# the MIT License: http://www.opensource.org/licenses/mit-license.php
diff --git a/paste/proxy.py b/paste/proxy.py
index 24860ff..c8075e7 100644
--- a/paste/proxy.py
+++ b/paste/proxy.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""
An application that proxies WSGI requests to a remote server.
diff --git a/paste/reloader.py b/paste/reloader.py
index 8f0d551..96614af 100644
--- a/paste/reloader.py
+++ b/paste/reloader.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""
A file monitor and server restarter.
diff --git a/paste/request.py b/paste/request.py
index 02828c4..40c50d6 100644
--- a/paste/request.py
+++ b/paste/request.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# (c) 2005 Ian Bicking and contributors
# This module is part of the Python Paste Project and is released under
# the MIT License: http://www.opensource.org/licenses/mit-license.php
diff --git a/paste/response.py b/paste/response.py
index c88cec0..d5cea3c 100644
--- a/paste/response.py
+++ b/paste/response.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""Routines to generate WSGI responses"""
############################################################
diff --git a/paste/transaction.py b/paste/transaction.py
index 45c915d..94910a5 100644
--- a/paste/transaction.py
+++ b/paste/transaction.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# (c) 2005 Clark C. Evans
# This module is part of the Python Paste Project and is released under
# the MIT License: http://www.opensource.org/licenses/mit-license.php
diff --git a/paste/translogger.py b/paste/translogger.py
index 49e7b8f..b2648fb 100644
--- a/paste/translogger.py
+++ b/paste/translogger.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
"""
Middleware for logging requests, using Apache combined log format
"""
diff --git a/paste/util/finddata.py b/paste/util/finddata.py
index e05ea4a..a717bf3 100644
--- a/paste/util/finddata.py
+++ b/paste/util/finddata.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# Note: you may want to copy this into your setup.py file verbatim, as
# you can't import this from another package, when you don't know if
# that package is installed yet.
diff --git a/paste/util/multidict.py b/paste/util/multidict.py
index 7ff33a1..a15d31d 100644
--- a/paste/util/multidict.py
+++ b/paste/util/multidict.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
from UserDict import DictMixin
class multidict(DictMixin):
diff --git a/paste/wdg_validate.py b/paste/wdg_validate.py
index 6033741..9d3d445 100644
--- a/paste/wdg_validate.py
+++ b/paste/wdg_validate.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
# Deprecated 18 Dec 2005
"""
Deprecated -- see ``paste.debug.wdg_validate``
diff --git a/paste/wsgiwrappers.py b/paste/wsgiwrappers.py
index 51c047a..b13eb7e 100644
--- a/paste/wsgiwrappers.py
+++ b/paste/wsgiwrappers.py
@@ -1,3 +1,5 @@
+# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
+# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
import paste.httpexceptions
from paste.request import EnvironHeaders, parse_formvars, parse_dict_querystring, get_cookie_dict, MultiDict
from paste.response import HeaderDict