summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2015-04-21 23:26:38 +0200
committerVictor Stinner <victor.stinner@gmail.com>2015-04-21 23:26:38 +0200
commita8a17ce1d575c26f35b71ef93038c746802cb777 (patch)
tree2f3f9a1c627c9ac84df116b1445f4c1d75deb228
parent43a2852a6c78c6c17db6ce856b844e28f0bc6ef8 (diff)
downloadpaste-a8a17ce1d575c26f35b71ef93038c746802cb777.tar.gz
Add tox.ini to run tests with tox on Python 2.6, 2.7 and 3.4
* MANIFEST.in: add regen-docs & tox.ini
-rw-r--r--.hgignore1
-rw-r--r--MANIFEST.in2
-rw-r--r--docs/news.txt2
-rw-r--r--setup.py13
-rw-r--r--tox.ini10
5 files changed, 27 insertions, 1 deletions
diff --git a/.hgignore b/.hgignore
index 09b0959..36cfdf7 100644
--- a/.hgignore
+++ b/.hgignore
@@ -11,3 +11,4 @@ syntax: glob
dist/
build/
docs/_build
+.tox
diff --git a/MANIFEST.in b/MANIFEST.in
index d310570..cc3f4ba 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -2,6 +2,8 @@ recursive-include docs *.txt *.css *.js
include docs/_templates/*.html
include docs/conf.py
include docs/test_server.ini
+include regen-docs
+include tox.ini
recursive-exclude docs/_build/_sources *
recursive-include docs/_build *.html
recursive-include tests *.txt *.py *.cgi *.html
diff --git a/docs/news.txt b/docs/news.txt
index 1239c87..58071f1 100644
--- a/docs/news.txt
+++ b/docs/news.txt
@@ -23,6 +23,8 @@ hg tip
* Fixed parsing of paths beginning with multiple forward slashes.
+* Add tox.ini to run tests with tox.
+
1.7.5.1
-------
diff --git a/setup.py b/setup.py
index 9ff4382..2197f98 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,19 @@
# Procedure to release a new version:
-# - run tests
+#
+# - run tests: run tox
# - update version in setup.py (__version__)
# - update changelog: docs/news.txt
# - modify setup.py: set RELEASE to True
+# - check that "python setup.py sdist" contains all files tracked by
+# the SCM (Mercurial): update MANIFEST.in if needed
+#
+# - hg ci
+# - hg tag VERSION
+# - hg push
+# - python setup.py register sdist bdist_wheel upload
+#
+# - increment version in setup.py (__version__)
+# - hg ci && hg push
# If true, then the svn revision won't be used to calculate the
# revision (set to True for real releases)
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..27fbcb8
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,10 @@
+[tox]
+envlist = py26,py27,py34
+
+[testenv]
+deps=
+ nose
+ six
+commands=
+ nosetests
+