summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile8
-rw-r--r--requirements.txt3
2 files changed, 10 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 780ba3e..68eced5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,2 +1,8 @@
test:
- python setup.py test \ No newline at end of file
+ python setup.py test
+
+pycco:
+ find oauthlib -name "*.py" -exec pycco -p -s reST {} \;
+
+pycco-clean:
+ rm -rf docs/oauthlib docs/pycco.css \ No newline at end of file
diff --git a/requirements.txt b/requirements.txt
new file mode 100644
index 0000000..6f4da3c
--- /dev/null
+++ b/requirements.txt
@@ -0,0 +1,3 @@
+docutils
+python-creole
+-e git+https://github.com/ternstor/pycco.git#egg=pycco