summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.rst12
-rw-r--r--docs/conf.py4
-rwxr-xr-xsetup.py2
3 files changed, 15 insertions, 3 deletions
diff --git a/README.rst b/README.rst
index 77d6ef6..3abe83f 100644
--- a/README.rst
+++ b/README.rst
@@ -95,6 +95,18 @@ details.
.. _`supported features`: http://oauthlib.readthedocs.org/en/latest/feature_matrix.html
+0.6.0: OAuth 1 & 2 provider API refactor with breaking changes
+
+* All endpoint methods change contract to return 3 values instead of 4. The new
+ signature is `headers`, `body`, `status code` where the initial `redirect_uri`
+ has been relocated to its rightful place inside headers as `Location`.
+
+* OAuth 1 Access Token Endpoint has a new required validator method
+ `invalidate_request_token`.
+
+* OAuth 1 Authorization Endpoint now returns a 200 response instead of 302 on
+ `oob` callbacks.
+
0.5.1: OAuth 1 provider fix for incorrect token param in nonce validation.
0.5.0: OAuth 1 provider refactor. OAuth 2 refresh token validation fix.
diff --git a/docs/conf.py b/docs/conf.py
index 3cf3219..a614242 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -48,9 +48,9 @@ copyright = u'2012, Idan Gazit and the Python Community'
# built documents.
#
# The short X.Y version.
-version = '0.5'
+version = '0.6'
# The full version, including alpha/beta/rc tags.
-release = '0.5.1'
+release = '0.6.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index c3e71b5..5be474a 100755
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,7 @@ requires = []
setup(
name='oauthlib',
- version='0.5.1',
+ version='0.6.0',
description='A generic, spec-compliant, thorough implementation of the OAuth request-signing logic',
long_description=fread('README.rst'),
author='Idan Gazit',