summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJonathan Huot <jonathan.huot@thomsonreuters.com>2018-03-20 09:44:27 +0100
committerJonathan Huot <jonathan.huot@thomsonreuters.com>2018-08-10 13:30:14 +0200
commita03cb7321d583897ac9865d9cb24b632081d16b1 (patch)
treee7c205d88a52f20f477530cbdc94eb6d45d10cd0 /tox.ini
parent9abadd701ce46b9df548a30d58fe13a636b222e5 (diff)
downloadoauthlib-a03cb7321d583897ac9865d9cb24b632081d16b1.tar.gz
Added README.rst/setup.py check for pypi
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini11
1 files changed, 10 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 8f3345e..03e25b1 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py34,py35,py36,pypy,docs
+envlist = py27,py34,py35,py36,pypy,docs,readme
[testenv]
deps=
@@ -19,3 +19,12 @@ deps=sphinx
changedir=docs
whitelist_externals=make
commands=make clean html
+
+# tox -e readme to mimick pypi long_description check
+[testenv:readme]
+skipsdist=True
+deps=readme
+whitelist_externals=echo
+commands=
+ python setup.py check -r -s
+ echo setup.py/long description is syntaxly correct