summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-09-14 16:17:25 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2018-09-14 16:25:07 -0700
commit037453c6f92b502eaae2acafe11161e4bb2e38bb (patch)
treeeeec102d494c217738ba24796fa9b708210d7b98 /tox.ini
parenta0f38f71cb8764bbff8dd2cdac5031a09086665e (diff)
downloadoauthlib-037453c6f92b502eaae2acafe11161e4bb2e38bb.tar.gz
Remove unmaintained nose dependency from tests
The nose project has ceased development. From their docs page: https://nose.readthedocs.io/ > Note to Users > > Nose has been in maintenance mode for the past several years and will > likely cease without a new person/team to take over maintainership. > New projects should consider using Nose2, py.test, or just plain > unittest/unittest2. Simplify test infrastructure by using the stdlib unittest discover command. One fewer dependency.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini5
1 files changed, 4 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index b736cf1..6f6c18c 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,10 @@ envlist = py27,py34,py35,py36,pypy,docs,readme
[testenv]
deps=
-rrequirements-test.txt
-commands=nosetests -s --with-coverage --cover-html --cover-html-dir={toxinidir}/htmlcov-{envname} --cover-erase --cover-package=oauthlib -w tests
+commands=
+ coverage run --source oauthlib -m unittest discover
+ coverage report
+
# tox -e docs to mimick readthedocs build.
# as of today, RTD is using python2.7 and doesn't run "setup.py install"