summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHsiaoming Yang <me@lepture.com>2013-11-04 11:24:51 +0800
committerHsiaoming Yang <me@lepture.com>2013-11-04 11:24:51 +0800
commitd1ad84e978192a8d73faf15ef6963c5cffba60bc (patch)
tree5596756709981f83ab47b919b0cf86c7ca5b904b /setup.py
parent1846ebff5c71a8c3bb0c9cccd29460f656f5a21b (diff)
downloadoauthlib-d1ad84e978192a8d73faf15ef6963c5cffba60bc.tar.gz
Add maintainer info and get version from oauthlib module.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5be474a..040f3e8 100755
--- a/setup.py
+++ b/setup.py
@@ -10,6 +10,7 @@ import sys
from os.path import dirname, join
from setuptools import setup, find_packages
+import oauthlib
def fread(fn):
@@ -26,11 +27,13 @@ requires = []
setup(
name='oauthlib',
- version='0.6.0',
+ version=oauthlib.__version__,
description='A generic, spec-compliant, thorough implementation of the OAuth request-signing logic',
long_description=fread('README.rst'),
author='Idan Gazit',
author_email='idan@gazit.me',
+ maintainer='Ib Lundgren',
+ maintainer_email='ib.lundgren@gmail.com',
url='https://github.com/idan/oauthlib',
platforms='any',
license='BSD',