summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorjason <com4@users.noreply.github.com>2021-02-12 04:36:13 -0700
committerGitHub <noreply@github.com>2021-02-12 13:36:13 +0200
commitb69fa53fd836dc559aa7fcd78ce075bcbe361629 (patch)
tree0a3bd1ba96a9f1339c4ef7c4063fc35814b423f0 /setup.py
parent89162b8a7a911f094674d0a77199ae226b71a656 (diff)
downloadoauthlib-b69fa53fd836dc559aa7fcd78ce075bcbe361629.tar.gz
Bump pyjwt and cryptography versions (#749)
* Bump pyjwt and cryptography versions Bump PyJWT to v2. No backward incompatible changes in the new version affects oauthlib. Bump minimum cryptography version to 3. PyJWT bumps cryptography as well plus older versions don't support newer versions of openssl. * Remove python 3.5 support; add python 3.8 support - Python 3.5 has reached end-of-life. - Add support for Python 3.8 - Move dist to bionic (xenial is EOL in April) - Upgrade pip in travis.yml's `before_install`. this should install a wheel for pyca/cryptography - Install rust for pypy builds. It is a requirement for cryptography as no pypy wheels exist. Co-authored-by: Asif Saif Uddin <auvipy@gmail.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index fed5814..124d534 100755
--- a/setup.py
+++ b/setup.py
@@ -16,8 +16,8 @@ def fread(fn):
return f.read()
-rsa_require = ['cryptography>=1.4.0']
-signedtoken_require = ['cryptography>=1.4.0', 'pyjwt>=1.6.0']
+rsa_require = ['cryptography>=3.0.0,<4']
+signedtoken_require = ['cryptography>=3.0.0,<4', 'pyjwt>=2.0.0,<3']
signals_require = ['blinker>=1.4.0']
setup(