summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-12-27 04:16:59 -0500
committerJonathan Huot <JonathanHuot@users.noreply.github.com>2018-12-27 10:16:59 +0100
commit729fb9fa17efb8a38bd50f5e180802d6034c351b (patch)
treefea56ad2127809750cebc9b20f5952680bd70d6b /setup.py
parentd8fe024751fad2b0fdb989f175f2b64d81f8880a (diff)
downloadoauthlib-729fb9fa17efb8a38bd50f5e180802d6034c351b.tar.gz
Pass python_requires argument to setuptools (#636)
Helps pip decide what version of the library to install. https://packaging.python.org/guides/distributing-packages-using-setuptools/#python-requires > If your project only runs on certain Python versions, setting the > python_requires argument to the appropriate PEP 440 version specifier > string will prevent pip from installing the project on other Python > versions. https://setuptools.readthedocs.io/en/latest/setuptools.html#new-and-changed-setup-keywords > python_requires > > A string corresponding to a version specifier (as defined in PEP 440) > for the Python version, used to specify the Requires-Python defined in > PEP 345.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index c0bdf38..3f822e0 100755
--- a/setup.py
+++ b/setup.py
@@ -36,6 +36,7 @@ setup(
platforms='any',
license='BSD',
packages=find_packages(exclude=('docs', 'tests', 'tests.*')),
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
extras_require={
'rsa': rsa_require,
'signedtoken': signedtoken_require,