summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGeorge Hickman <george@ghickman.co.uk>2012-03-12 21:11:07 -0700
committerDavid Gouldin <david@gould.in>2012-03-12 21:56:35 -0700
commit3983c7ef39503a14ffa029fa48a0a4301ba7d89c (patch)
tree6100a2c7c53330de7f3503275e973947b0f1950b /setup.py
parentd9ff221a9165eb645f64fa03893cc9b59599469f (diff)
downloadoauthlib-3983c7ef39503a14ffa029fa48a0a4301ba7d89c.tar.gz
Add basic setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 20 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..34ff57a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,20 @@
+from os.path import dirname, join
+from setuptools import setup, find_packages
+
+
+def fread(fn):
+ with open(join(dirname(__file__), fn), 'r') as f:
+ return f.read()
+
+setup(
+ name = 'oauthlib',
+ version = '0.0.1',
+ description = 'Python implementation of OAuth 1.0a',
+ long_description = fread('README.rst'),
+ author = '',
+ author_email = '',
+ url = 'https://github.com/idangazit/oauthlib',
+ license = fread('LICENSE'),
+ packages = find_packages(exclude=('tests', 'docs')),
+)
+