summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRichard Connon <richard@connon.me.uk>2021-10-02 16:45:42 +0100
committerAsif Saif Uddin <auvipy@gmail.com>2021-10-03 00:13:26 +0600
commit354d4354e7b78070bc70dcdca598a6027e9642d4 (patch)
tree8a7dbe8befa5f30e4fac9d73158a8635d1f94c39 /setup.py
parent5cf4c3d7fb59338050392147546155d5e9ee197e (diff)
downloadoauthlib-354d4354e7b78070bc70dcdca598a6027e9642d4.tar.gz
Remove upper bound on cryptography version
Cryptography has adopted a firefox-style versioning system where new feature releases always have new major versions even if they don't have backwards incompatible changes. This means that an upper bound on the dependency does not make sense.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 124d534..72579dc 100755
--- a/setup.py
+++ b/setup.py
@@ -16,8 +16,8 @@ def fread(fn):
return f.read()
-rsa_require = ['cryptography>=3.0.0,<4']
-signedtoken_require = ['cryptography>=3.0.0,<4', 'pyjwt>=2.0.0,<3']
+rsa_require = ['cryptography>=3.0.0']
+signedtoken_require = ['cryptography>=3.0.0', 'pyjwt>=2.0.0,<3']
signals_require = ['blinker>=1.4.0']
setup(