summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJonathan Huot <jonathan.huot@thomsonreuters.com>2018-07-17 15:21:58 +0200
committerJonathan Huot <jonathan.huot@thomsonreuters.com>2018-07-17 15:39:40 +0200
commitf991b5759a4728fd99d36f98e2dd171b300fb7c2 (patch)
tree38aa55e2aa98bdca51fed33ab4bee8e182c0cffc /Makefile
parentcfcbe99477a5d392175970f9c2e16b7d8ce138fb (diff)
downloadoauthlib-f991b5759a4728fd99d36f98e2dd171b300fb7c2.tar.gz
Added flask-dance tests, see #553
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index f9cc4ab..64fdc8e 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,7 @@ clean: clean-eggs clean-build
@find . -iname '__pycache__' -delete
rm -rf .tox
rm -rf bottle-oauthlib
+ rm -rf dance
rm -rf django-oauth-toolkit
rm -rf flask-oauthlib
rm -rf requests-oauthlib
@@ -65,6 +66,13 @@ requests:
cd requests-oauthlib 2>/dev/null || git clone https://github.com/requests/requests-oauthlib.git
cd requests-oauthlib && sed -i.old 's,deps=,deps = --editable=file://{toxinidir}/../[signedtoken],' tox.ini && sed -i.old '/oauthlib/d' requirements.txt && tox
+dance:
+ #---------------------------
+ # Library singingwolfboy/flask-dance
+ # Contacts: singingwolfboy
+ cd flask-dance 2>/dev/null || git clone https://github.com/singingwolfboy/flask-dance.git
+ cd flask-dance && sed -i.old 's,deps=,deps = --editable=file://{toxinidir}/../,' tox.ini && sed -i.old '/oauthlib/d' requirements.txt && tox
+
.DEFAULT_GOAL := all
-.PHONY: clean test bottle django flask requests
-all: clean test bottle django flask requests
+.PHONY: clean test bottle dance django flask requests
+all: clean test bottle dance django flask requests