summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorWiliam Souza <wiliamsouza83@gmail.com>2018-06-05 11:33:21 -0300
committerOmer Katz <omer.drow@gmail.com>2018-06-05 17:33:21 +0300
commitd5a4d5ea0eab04ddddefac7d1e7a4902fc469286 (patch)
tree580faf95f8f7bed257b2dac1d29c26c3d9d1b219 /Makefile
parenta102731c88f496b557dedd4024fb9b82801d134a (diff)
downloadoauthlib-d5a4d5ea0eab04ddddefac7d1e7a4902fc469286.tar.gz
OpenID Connect split (#525)
* Add command to clean up builds to makefile * Fix docs strings for endpoints pre_configured * Chnage grant_types.openid_connect to include a deprecation warning be a backward compatible * Fix doc string for rfc6749.request_validator * Remove unused import * Change import to be explicity * Move JWTTokenTestCase to openid.connect.core.test_token * Move JWTToken to oauthlib.openid.connect.core.tokens * Move to openid connect test * Move openid connect exceptions to its own file * Remove openid connect from oauth2 server * Remove JWTToken from oauth tokens * Remove grant_types.openid_connect file * Add oauthlib/openid estructure and tests
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 8571a91..f9cc4ab 100644
--- a/Makefile
+++ b/Makefile
@@ -12,13 +12,27 @@
# Since these contacts will be addressed with Github mentions they
# need to be Github users (for now)(sorry Bitbucket).
#
-clean:
+clean: clean-eggs clean-build
+ @find . -iname '*.pyc' -delete
+ @find . -iname '*.pyo' -delete
+ @find . -iname '*~' -delete
+ @find . -iname '*.swp' -delete
+ @find . -iname '__pycache__' -delete
rm -rf .tox
rm -rf bottle-oauthlib
rm -rf django-oauth-toolkit
rm -rf flask-oauthlib
rm -rf requests-oauthlib
+clean-eggs:
+ @find . -name '*.egg' -print0|xargs -0 rm -rf --
+ @rm -rf .eggs/
+
+clean-build:
+ @rm -fr build/
+ @rm -fr dist/
+ @rm -fr *.egg-info
+
test:
tox
@@ -51,7 +65,6 @@ requests:
cd requests-oauthlib 2>/dev/null || git clone https://github.com/requests/requests-oauthlib.git
cd requests-oauthlib && sed -i.old 's,deps=,deps = --editable=file://{toxinidir}/../[signedtoken],' tox.ini && sed -i.old '/oauthlib/d' requirements.txt && tox
-
.DEFAULT_GOAL := all
.PHONY: clean test bottle django flask requests
all: clean test bottle django flask requests