summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJonathan Huot <JonathanHuot@users.noreply.github.com>2018-03-18 11:06:51 +0100
committerPieter Ennes <pieter@ennes.nl>2018-03-18 10:06:51 +0000
commitad61175827cddda8f8cb3cccc14f9f5eb9887ca7 (patch)
treedc0b51246a2234468f9a33328698c887982f8ad6 /Makefile
parentf398fdb7b0ac7b0aa11408d11a4358524360ac77 (diff)
downloadoauthlib-ad61175827cddda8f8cb3cccc14f9f5eb9887ca7.tar.gz
Fixed "make" command to test upstream with local oauthlib. (#522)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile74
1 files changed, 42 insertions, 32 deletions
diff --git a/Makefile b/Makefile
index 259fe9c..8571a91 100644
--- a/Makefile
+++ b/Makefile
@@ -1,47 +1,57 @@
-PYS = py27,py34,pypy
+# Downstream tests (Don't be evil)
+#
+# Try and not break the libraries below by running their tests too.
+#
+# Unfortunately there is no neat way to run downstream tests AFAIK
+# Until we have a proper downstream testing system we will
+# stick to this Makefile.
+#---------------------------
+# HOW TO ADD NEW DOWNSTREAM LIBRARIES
+#
+# Please specify your library as well as primary contacts.
+# Since these contacts will be addressed with Github mentions they
+# need to be Github users (for now)(sorry Bitbucket).
+#
+clean:
+ rm -rf .tox
+ rm -rf bottle-oauthlib
+ rm -rf django-oauth-toolkit
+ rm -rf flask-oauthlib
+ rm -rf requests-oauthlib
test:
- # Test OAuthLib
- tox -e "$(PYS)"
- #
- # Downstream tests (Don't be evil)
- #
- # Try and not break the libraries below by running their tests too.
- #
- # Unfortunately there is no neat way to run downstream tests AFAIK
- # Until we have a proper downstream testing system we will
- # stick to this Makefile.
+ tox
+
+bottle:
#---------------------------
- # HOW TO ADD NEW DOWNSTREAM LIBRARIES
- #
- # Please specify your library as well as primary contacts.
- # Since these contacts will be addressed with Github mentions they
- # need to be Github users (for now)(sorry Bitbucket).
- #
+ # Library thomsonreuters/bottle-oauthlib
+ # Contacts: Jonathan.Huot
+ cd bottle-oauthlib 2>/dev/null || git clone https://github.com/thomsonreuters/bottle-oauthlib.git
+ cd bottle-oauthlib && sed -i.old 's,deps =,deps= --editable=file://{toxinidir}/../,' tox.ini && sed -i.old '/oauthlib/d' requirements.txt && tox
+
+flask:
#---------------------------
# Library: lepture/flask-oauthLib
# Contacts: lepture,widnyana
- git clone https://github.com/lepture/flask-oauthlib.git
- cd flask-oauthlib && cp ../tox.ini . && sed -i 's/py32,py33,py34,//' tox.ini && sed -i '/mock/a \ Flask-SQLAlchemy' tox.ini && tox -e "$(PYS)"
- rm -rf flask-oauthlib
+ cd flask-oauthlib 2>/dev/null || git clone https://github.com/lepture/flask-oauthlib.git
+ cd flask-oauthlib && sed -i.old 's,deps =,deps= --editable=file://{toxinidir}/../,' tox.ini && sed -i.old '/oauthlib/d' requirements.txt && tox
+
+django:
#---------------------------
# Library: evonove/django-oauth-toolkit
# Contacts: evonove,masci
# (note: has tox.ini already)
- git clone https://github.com/evonove/django-oauth-toolkit.git
- cd django-oauth-toolkit && tox -e "$(PYS)"
- rm -rf django-oauth-toolkit
+ cd django-oauth-toolkit 2>/dev/null || git clone https://github.com/evonove/django-oauth-toolkit.git
+ cd django-oauth-toolkit && sed -i.old 's,deps =,deps= --editable=file://{toxinidir}/../,' tox.ini && tox -e py27,py35,py36
+
+requests:
#---------------------------
# Library requests/requests-oauthlib
# Contacts: ib-lundgren,lukasa
- git clone https://github.com/requests/requests-oauthlib.git
- cd requests-oauthlib && cp ../tox.ini . && sed -i '/mock/a \ requests' tox.ini && tox -e "$(PYS)"
- rm -rf requests-oauthlib
- #---------------------------
- #
+ cd requests-oauthlib 2>/dev/null || git clone https://github.com/requests/requests-oauthlib.git
+ cd requests-oauthlib && sed -i.old 's,deps=,deps = --editable=file://{toxinidir}/../[signedtoken],' tox.ini && sed -i.old '/oauthlib/d' requirements.txt && tox
-pycco:
- find oauthlib -name "*.py" -exec pycco -p -s reST {} \;
-pycco-clean:
- rm -rf docs/oauthlib docs/pycco.css
+.DEFAULT_GOAL := all
+.PHONY: clean test bottle django flask requests
+all: clean test bottle django flask requests