summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorIb Lundgren <ib.lundgren@gmail.com>2014-06-25 18:09:23 +0100
committerIb Lundgren <ib.lundgren@gmail.com>2014-06-25 18:09:23 +0100
commit3c987c3948218933842034ee1e127d1f9a1bf61a (patch)
tree597b72a1cddd9b311a82e208d7ef0ed536656f2b /Makefile
parent04095295e4cf0d49d1f45707f68addeed7704caa (diff)
downloadoauthlib-3c987c3948218933842034ee1e127d1f9a1bf61a.tar.gz
Test key libraries using oauthlib with make test #254.
It is important, especially for releases, to keep disruptions low and not break the code for people using oauthlib. To start off we include 3 libraries which master versions on Github can be tested against local oauthlib version. To include another library, send a PR :)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8a4076d..8d3b1a5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,21 @@
test:
- nosetests -w tests
+ # Test OAuthLib
+ tox
+ #
+ # Try and not break these libraries by running their tests too.
+ #
+ # Flask-OAuthLib
+ git clone https://github.com/lepture/flask-oauthlib.git
+ cd flask-oauthlib && cp ../tox.ini . && sed -i 's/py32,py33,py34,//' tox.ini && sed -i '/mock/a \ Flask-SQLAlchemy' tox.ini && tox
+ rm -rf flask-oauthlib
+ # Django-OAuth-Toolkit (has tox.ini already)
+ git clone https://github.com/evonove/django-oauth-toolkit.git
+ cd django-oauth-toolkit && tox
+ rm -rf django-oauth-toolkit
+ # Requests-OAuthLib
+ git clone https://github.com/requests/requests-oauthlib.git
+ cd requests-oauthlib && cp ../tox.ini . && sed -i '/mock/a \ requests' tox.ini && tox
+ rm -rf requests-oauthlib
pycco:
find oauthlib -name "*.py" -exec pycco -p -s reST {} \;