summaryrefslogtreecommitdiff
path: root/CHANGELOG.rst
diff options
context:
space:
mode:
authorJonathan Huot <jonathan.huot@thomsonreuters.com>2018-12-28 19:23:57 +0100
committerJonathan Huot <jonathan.huot@thomsonreuters.com>2018-12-28 19:29:29 +0100
commit45135a25d4dde6f0d1d6a9b735a40159ac391c11 (patch)
treeacde12426070a999c571339b947f7f2308acde8b /CHANGELOG.rst
parentd4f48845a7ceec5bbd658cf2b478f7b6d5cfee2e (diff)
downloadoauthlib-45135a25d4dde6f0d1d6a9b735a40159ac391c11.tar.gz
Update Changelog to 3.0.0
Diffstat (limited to 'CHANGELOG.rst')
-rw-r--r--CHANGELOG.rst42
1 files changed, 40 insertions, 2 deletions
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index fd53769..3dea103 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -1,9 +1,33 @@
Changelog
=========
-Unreleased
+3.0.0 (2019-01-01)
------------------
-
+OAuth2.0 Provider - outstanding Features
+
+* OpenID Connect Core support
+* RFC7662 Introspect support
+* RFC8414 OAuth2.0 Authorization Server Metadata support (#605)
+* RFC7636 PKCE support (#617 #624)
+
+OAuth2.0 Provider - Bugfixes
+
+* Add "request" to confirm_redirect_uri #504
+* confirm_redirect_uri/get_default_redirect_uri has a bit changed #445
+* empty scopes no longer raise exceptions for implicit and authorization_code #475 / #406
+* invalid_client is now a FatalError #606
+* Changed errors status code from 401 to 400:
+- invalid_grant: #264
+- invalid_scope: #620
+- access_denied/unauthorized_client/consent_required/login_required #623
+- 401 must have WWW-Authenticate HTTP Header set. #623
+
+OAuth2.0 Client - Bugfixes / Changes:
+
+* expires_in in Implicit flow is now an integer #569
+* expires is no longer overriding expires_in #506
+* parse_request_uri_response is now required #499
+* Unknown error=xxx raised by OAuth2 providers was not understood #431
* OAuth2's `prepare_token_request` supports sending an empty string for `client_id` (#585)
* OAuth2's `WebApplicationClient.prepare_request_body` was refactored to better
support sending or omitting the `client_id` via a new `include_client_id` kwarg.
@@ -11,6 +35,20 @@ Unreleased
a `client_id` parameter is submitted; the already configured `self.client_id`
is the preferred option. (#585)
+OAuth1.0 Client:
+
+* Support for HMAC-SHA256 #498
+
+General fixes:
+
+* $ and ' are allowed to be unencoded in query strings #564
+* Request attributes are no longer overriden by HTTP Headers #409
+* Removed unnecessary code for handling python2.6
+* Add support of python3.7 #621
+* Several minors updates to setup.py and tox
+* Set pytest as the default unittest framework
+
+
2.1.0 (2018-05-21)
------------------