summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2021-10-11 18:45:05 +0300
committerAsif Saif Uddin <auvipy@gmail.com>2021-10-11 22:30:55 +0600
commit757baf4cddf5216374932d756aaf75d0bde88b64 (patch)
treea355de32af04bdb3698e3f3e9cbce093f010c0d0
parent354d4354e7b78070bc70dcdca598a6027e9642d4 (diff)
downloadoauthlib-757baf4cddf5216374932d756aaf75d0bde88b64.tar.gz
Add support for Python 3.9 and 3.10
-rw-r--r--.travis.yml12
-rwxr-xr-xsetup.py2
-rw-r--r--tox.ini2
3 files changed, 11 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index e0e543d..89af15d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,13 +4,17 @@ dist: bionic
cache: pip
matrix:
include:
- - python: 3.6
+ - python: "3.6"
env: TOXENV=py36
- - python: 3.7
+ - python: "3.7"
env: TOXENV=py37
- - python: 3.8
+ - python: "3.8"
env: TOXENV=py38,bandit,docs,readme
- - python: pypy3
+ - python: "3.9"
+ env: TOXENV=py39
+ - python: "3.10-dev"
+ env: TOXENV=py310
+ - python: "pypy3"
env: TOXENV=pypy3
before_install:
- python -m pip install --upgrade pip setuptools
diff --git a/setup.py b/setup.py
index 72579dc..0192458 100755
--- a/setup.py
+++ b/setup.py
@@ -54,6 +54,8 @@ setup(
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Programming Language :: Python :: 3 :: Only',
'Programming Language :: Python :: Implementation',
'Programming Language :: Python :: Implementation :: CPython',
diff --git a/tox.ini b/tox.ini
index cec4ba5..903f202 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py36,py37,py38,pypy3,docs,readme,bandit,isort
+envlist = py36,py37,py38,py39,py310,pypy3,docs,readme,bandit,isort
[testenv]
deps=