summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjason <jason@zzq.org>2021-02-08 14:22:26 -0700
committerAsif Saif Uddin <auvipy@gmail.com>2021-02-10 19:05:47 +0600
commit637c8945f2ba1481927478db7d1fa09de43c265b (patch)
tree67e638487090acc01de8ba24f8698a01567c2e48
parentd54965b86ce4ede956db70baff0b3d5e9182a007 (diff)
downloadoauthlib-637c8945f2ba1481927478db7d1fa09de43c265b.tar.gz
Remove python 3.5 support; add python 3.8 support
- Python 3.5 has reached end-of-life. - Add support for Python 3.8 - Move dist to bionic (xenial is EOL in April) - Upgrade pip in travis.yml's `before_install`. this should install a wheel for pyca/cryptography - Install rust for pypy builds. It is a requirement for cryptography as no pypy wheels exist.
-rw-r--r--.travis.yml19
-rw-r--r--README.rst2
-rwxr-xr-xsetup.py4
-rw-r--r--tox.ini8
4 files changed, 17 insertions, 16 deletions
diff --git a/.travis.yml b/.travis.yml
index fbf676b..69eb935 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,22 +1,23 @@
language: python
-python: 3.7
-dist: xenial
+python: 3.8
+dist: bionic
cache: pip
matrix:
include:
- - python: 3.5
- env: TOXENV=py35
- python: 3.6
env: TOXENV=py36
- python: 3.7
env: TOXENV=py37
- - python: 3.7
+ - python: 3.8
+ env: TOXENV=py38
+ - python: 3.8
env: TOXENV=bandit
- - python: pypy3.5
+ - python: pypy3
env: TOXENV=pypy3
-install:
-- pip install -U setuptools
-- pip install tox coveralls
+before_install:
+ - python -m pip install --upgrade pip setuptools
+ - python -m pip install tox coveralls
+ - if [ "$TOXENV" == "pypy3" ]; then curl --proto '=https' --tlsv1.2 -sSf https://sh.rustup.rs | sh -s -- -y && source $HOME/.cargo/env ; fi
script: tox
after_success: COVERALLS_PARALLEL=true coveralls
notifications:
diff --git a/README.rst b/README.rst
index 0b42133..56e41c1 100644
--- a/README.rst
+++ b/README.rst
@@ -2,7 +2,7 @@ OAuthLib - Python Framework for OAuth1 & OAuth2
===============================================
*A generic, spec-compliant, thorough implementation of the OAuth request-signing
-logic for Python 3.5+.
+logic for Python 3.6+.
.. image:: https://travis-ci.org/oauthlib/oauthlib.svg?branch=master
:target: https://travis-ci.org/oauthlib/oauthlib
diff --git a/setup.py b/setup.py
index 0babb45..fed5814 100755
--- a/setup.py
+++ b/setup.py
@@ -34,7 +34,7 @@ setup(
platforms='any',
license='BSD',
packages=find_packages(exclude=('docs', 'tests', 'tests.*')),
- python_requires='>=3.5',
+ python_requires='>=3.6',
extras_require={
'rsa': rsa_require,
'signedtoken': signedtoken_require,
@@ -51,9 +51,9 @@ setup(
'Operating System :: POSIX :: Linux',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3 :: Only',
'Programming Language :: Python :: Implementation',
'Programming Language :: Python :: Implementation :: CPython',
diff --git a/tox.ini b/tox.ini
index aad4538..deb7cc7 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py35,py36,py37,pypy,pypy3,docs,readme,bandit,isort
+envlist = py36,py37,py38,pypy,pypy3,docs,readme,bandit,isort
[testenv]
deps=
@@ -22,21 +22,21 @@ commands=make clean html
# tox -e readme to mimick PyPI long_description check
[testenv:readme]
-basepython=python3.7
+basepython=python3.8
deps=twine>=1.12.0
whitelist_externals=echo
commands=
twine check dist/*
[testenv:bandit]
-basepython=python3.7
+basepython=python3.8
skipsdist=True
deps=bandit
commands=bandit -b bandit.json -r oauthlib/
whitelist_externals=bandit
[testenv:isort]
-basepython = python3.7
+basepython = python3.8
usedevelop = false
deps = isort
changedir = {toxinidir}