summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Huot <JonathanHuot@users.noreply.github.com>2019-08-30 11:02:35 +0200
committerGitHub <noreply@github.com>2019-08-30 11:02:35 +0200
commit114dab8b5c6f34fa2936e22e0b33c27aa65096d2 (patch)
treeef1eccc00ac4198d83a8cacda585a2f658bdc11e
parent86da2ec58789adc1d1d98ac9f8c9703863e6f1ef (diff)
parent1f3fc4bfd4fd51711798186591bf3e3ba5a894be (diff)
downloadoauthlib-114dab8b5c6f34fa2936e22e0b33c27aa65096d2.tar.gz
Merge branch 'master' into doc-improvement
-rw-r--r--.travis.yml2
-rw-r--r--README.rst2
-rw-r--r--docs/contributing.rst21
-rwxr-xr-xsetup.py3
-rw-r--r--tox.ini2
5 files changed, 15 insertions, 15 deletions
diff --git a/.travis.yml b/.travis.yml
index f2e68a6..5241b81 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,8 +7,6 @@ matrix:
include:
- python: 2.7
env: TOXENV=py27
- - python: 3.4
- env: TOXENV=py34
- python: 3.5
env: TOXENV=py35
- python: 3.6
diff --git a/README.rst b/README.rst
index 2900ecc..96871b6 100644
--- a/README.rst
+++ b/README.rst
@@ -2,7 +2,7 @@ OAuthLib - Python Framework for OAuth1 & OAuth2
===============================================
*A generic, spec-compliant, thorough implementation of the OAuth request-signing
-logic for Python 2.7 and 3.4+.*
+logic for Python 2.7 and 3.5+.*
.. image:: https://travis-ci.org/oauthlib/oauthlib.svg?branch=master
:target: https://travis-ci.org/oauthlib/oauthlib
diff --git a/docs/contributing.rst b/docs/contributing.rst
index e101f70..5473aab 100644
--- a/docs/contributing.rst
+++ b/docs/contributing.rst
@@ -152,7 +152,7 @@ request that fails this test suite will be **rejected**.
Testing multiple versions of Python
-----------------------------------
-OAuthLib supports Python 2.7, 3.4, 3.5, 3.6 and PyPy. Testing
+OAuthLib supports Python 2.7, 3.5, 3.6, 3.7 and PyPy 2.7 & PyPy 3. Testing
all versions conveniently can be done using `Tox`_.
.. sourcecode:: bash
@@ -160,20 +160,23 @@ all versions conveniently can be done using `Tox`_.
$ tox
Tox requires you to have `virtualenv`_ installed as well as respective python
-version. For Ubuntu you can easily install all after adding one ppa.
+version. We recommend using `pyenv`_ to install those Python versions.
+
+We recommend using the latest patch version for each Python version we support and the latest PyPy versions.
+The versions beloew may not be up to date.
.. sourcecode:: bash
- $ sudo add-apt-repository ppa:fkrull/deadsnakes
- $ sudo apt-get update
- $ sudo apt-get install python2.6 python2.6-dev
- $ sudo apt-get install python2.7 python2.7-dev
- $ sudo apt-get install python3.2 python3.2-dev
- $ sudo apt-get install python3.3 python3.3-dev
- $ sudo apt-get install pypy pypy-dev
+ $ pyenv install 2.7.16
+ $ pyenv install 3.5.7
+ $ pyenv install 3.6.9
+ $ pyenv install 3.7.4
+ $ pyenv install pypy2.7-7.1.1
+ $ pyenv install pypy3.6-7.1.1
.. _`Tox`: https://tox.readthedocs.io/en/latest/install.html
.. _`virtualenv`: https://virtualenv.pypa.io/en/latest/installation/
+.. _`pyenv`: https://github.com/pyenv/pyenv
Test upstream applications
-----------------------------------
diff --git a/setup.py b/setup.py
index 1de8510..7c4e8c4 100755
--- a/setup.py
+++ b/setup.py
@@ -37,7 +37,7 @@ setup(
platforms='any',
license='BSD',
packages=find_packages(exclude=('docs', 'tests', 'tests.*')),
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, != 3.4.*',
extras_require={
'rsa': rsa_require,
'signedtoken': signedtoken_require,
@@ -56,7 +56,6 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
diff --git a/tox.ini b/tox.ini
index 4670c91..1b03598 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py34,py35,py36,py37,pypy,pypy3,docs,readme,bandit
+envlist = py27,py35,py36,py37,pypy,pypy3,docs,readme,bandit
[testenv]
deps=