summaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorJulian Taylor <jtaylor.debian@googlemail.com>2014-01-16 00:32:19 +0100
committerJulian Taylor <jtaylor.debian@googlemail.com>2014-01-16 00:38:34 +0100
commit8ef97a9c21f24964f4cee2e56ec9141b217ff186 (patch)
tree92fb74d7451d7ccb21ca39d35cf0916921732809 /tools
parent796ac14fb05694365fb423e5684ccac4330470f2 (diff)
downloadnumpy-8ef97a9c21f24964f4cee2e56ec9141b217ff186.tar.gz
TST: add travis test using python-dbg
python-dbg adds couple extra asserts on reference counts, memory allocation and also enables a few numpy internal asserts.
Diffstat (limited to 'tools')
-rwxr-xr-xtools/travis-test.sh13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/travis-test.sh b/tools/travis-test.sh
index 8c9495027..b02c41d36 100755
--- a/tools/travis-test.sh
+++ b/tools/travis-test.sh
@@ -19,7 +19,11 @@ setup_base()
# have been removed from master. (See gh-2765, gh-2768.) Using 'pip
# install' also has the advantage that it tests that numpy is 'pip
# install' compatible, see e.g. gh-2766...
+if [ -z "$USE_DEBUG" ]; then
$PIP install .
+else
+ $PYTHON setup.py build_ext --inplace
+fi
}
setup_chroot()
@@ -75,6 +79,9 @@ setup_bento()
run_test()
{
+ if [ -n "$USE_DEBUG" ]; then
+ export PYTHONPATH=$PWD
+ fi
# We change directories to make sure that python won't find the copy
# of numpy in the source directory.
mkdir -p empty
@@ -89,6 +96,12 @@ run_test()
# travis venv tests override python
PYTHON=${PYTHON:-python}
PIP=${PIP:-pip}
+
+if [ -n "$USE_DEBUG" ]; then
+ sudo apt-get install -qq -y --force-yes python3-dbg python3-dev python3-nose
+ PYTHON=python3-dbg
+fi
+
export PYTHON
export PIP
if [ "$USE_CHROOT" != "1" ] && [ "$USE_BENTO" != "1" ]; then