summaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorJulian Taylor <jtaylor.debian@googlemail.com>2017-09-01 10:19:26 +0200
committerJulian Taylor <jtaylor.debian@googlemail.com>2017-09-01 11:07:15 +0200
commit26d7e398ebf6352fdf1c5a659b39646da36b03e4 (patch)
tree9864108577171810299be7c8cf34d387d6c5a6ca /tools
parent229d7afc0db9ebc333781cf681c78ea8a8b342aa (diff)
downloadnumpy-26d7e398ebf6352fdf1c5a659b39646da36b03e4.tar.gz
MAINT: remove -Wsign-compare from warnings
Too noise and not really worth fixing.
Diffstat (limited to 'tools')
-rwxr-xr-xtools/travis-test.sh16
1 files changed, 6 insertions, 10 deletions
diff --git a/tools/travis-test.sh b/tools/travis-test.sh
index 1d3b3f909..b5c40cf25 100755
--- a/tools/travis-test.sh
+++ b/tools/travis-test.sh
@@ -35,6 +35,10 @@ werrors+="-Werror=nonnull -Werror=pointer-arith"
setup_base()
{
+ # use default python flags but remoge sign-compare
+ sysflags="$($PYTHON -c "from distutils import sysconfig; \
+ print (sysconfig.get_config_var('CFLAGS'))")"
+ export CFLAGS="$sysflags $werrors -Wlogical-op -Wno-sign-compare"
# We used to use 'setup.py install' here, but that has the terrible
# behaviour that if a copy of the package is already installed in the
# install location, then the new copy just gets dropped on top of it.
@@ -45,17 +49,9 @@ setup_base()
# the advantage that it tests that numpy is 'pip install' compatible,
# see e.g. gh-2766...
if [ -z "$USE_DEBUG" ]; then
- if [ -z "$IN_CHROOT" ]; then
- $PIP install -v . 2>&1 | tee log
- else
- sysflags="$($PYTHON -c "from distutils import sysconfig; \
- print (sysconfig.get_config_var('CFLAGS'))")"
- CFLAGS="$sysflags $werrors -Wlogical-op" $PIP install -v . 2>&1 | tee log
- fi
+ $PIP install -v . 2>&1 | tee log
else
- sysflags="$($PYTHON -c "from distutils import sysconfig; \
- print (sysconfig.get_config_var('CFLAGS'))")"
- CFLAGS="$sysflags $werrors" $PYTHON setup.py build_ext --inplace 2>&1 | tee log
+ $PYTHON setup.py build_ext --inplace 2>&1 | tee log
fi
grep -v "_configtest" log \
| grep -vE "ld returned 1|no previously-included files matching|manifest_maker: standard file '-c'" \