summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormattip <matti.picus@gmail.com>2019-03-20 12:39:53 +0200
committermattip <matti.picus@gmail.com>2019-05-20 18:45:27 +0300
commitfa8af41c9d375072b2c7af66e5f7f01df4754841 (patch)
treea70e8ac590d1aa7b04799b8c4deb3d67603e856b /setup.py
parent6e386c05c292da49224fcab372013a6d4247ae3b (diff)
downloadnumpy-fa8af41c9d375072b2c7af66e5f7f01df4754841.tar.gz
BUILD: move files out of _randomgen
first cut at building randomgen upgrade 'cythonize' and fix absolute imports to relative define NPY_NO_DEPRECATED_API and fix other warnings enable pgc64 by always using PCG_EMULATED_MATH refactor so import randomgen works add TODO comments for pcg64 improvements fix imports, module name in setup.py; remove _testing make cythonize non-recursive, restore examples to proper place update to randomgen 7bca296c0b9 replace mtrand with LegacyGenerator, tweak for compatibility port f879ef4 to fix GH10839 minimized difference between generator.pyx and _legacy.pyx fix namespace in doctests, mark results that are random update to randomgen commit 95c8cdd1c Incorporate testing of edge cases into main tests Rename test files to describe their purpose Import import locations to reflect numpy paths Correct tolerance on float32 tests Remove set_printoptions Remove complex normal Remove future imports Pull in BasicRNG source changes from original author Small doc fixes _mtrand => _rand Improve consistency of nan handling Prevent nans prducing values from int functions add randomgen documentation to the tree
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py13
1 files changed, 7 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index e88723820..d7fa3f544 100755
--- a/setup.py
+++ b/setup.py
@@ -225,12 +225,13 @@ class sdist_checked(sdist):
def generate_cython():
cwd = os.path.abspath(os.path.dirname(__file__))
print("Cythonizing sources")
- p = subprocess.call([sys.executable,
- os.path.join(cwd, 'tools', 'cythonize.py'),
- 'numpy/random'],
- cwd=cwd)
- if p != 0:
- raise RuntimeError("Running cythonize failed!")
+ for d in ('mtrand', 'randomgen', 'randomgen/legacy'):
+ p = subprocess.call([sys.executable,
+ os.path.join(cwd, 'tools', 'cythonize.py'),
+ 'numpy/random/{0}'.format(d)],
+ cwd=cwd)
+ if p != 0:
+ raise RuntimeError("Running cythonize failed!")
def parse_setuppy_commands():