summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatthew Brett <matthew.brett@gmail.com>2014-05-03 14:04:11 -0700
committerMatthew Brett <matthew.brett@gmail.com>2014-05-03 14:04:11 -0700
commit99cbdbacc23041392aac3f8cc60916d603ee9b1c (patch)
tree00994025f6068095d1ea71b0fb6f4707bdfbb152 /setup.py
parent61c699e5e1bf8b4b85ffd72a99691138d5674b50 (diff)
downloadnumpy-99cbdbacc23041392aac3f8cc60916d603ee9b1c.tar.gz
BUG: cythonize sources for wheel build
Wheel build was not cythonizing sources, giving a compile error because needed `numpy/random/mtrand/mtrand.c` was missing.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 3 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 6bb746955..12eb29093 100755
--- a/setup.py
+++ b/setup.py
@@ -228,12 +228,10 @@ def setup_package():
FULLVERSION, GIT_REVISION = get_version_info()
metadata['version'] = FULLVERSION
- elif len(sys.argv) >= 2 and sys.argv[1] == 'bdist_wheel':
- # bdist_wheel needs setuptools
- import setuptools
- from numpy.distutils.core import setup
- metadata['configuration'] = configuration
else:
+ if len(sys.argv) >= 2 and sys.argv[1] == 'bdist_wheel':
+ # bdist_wheel needs setuptools
+ import setuptools
from numpy.distutils.core import setup
cwd = os.path.abspath(os.path.dirname(__file__))
if not os.path.exists(os.path.join(cwd, 'PKG-INFO')):