summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Cournapeau <cournape@gmail.com>2009-09-18 10:10:39 +0000
committerDavid Cournapeau <cournape@gmail.com>2009-09-18 10:10:39 +0000
commit5032b52732b2e8e6d60be09646d65bf0051a3161 (patch)
tree3374d1f1eedc20b26241d00d2c999655bd5a85e1 /setup.py
parent599b0f1e83494c56d01ac24d7605bc3e8da0cd6e (diff)
downloadnumpy-5032b52732b2e8e6d60be09646d65bf0051a3161.tar.gz
Fix svn revision parsing under win32.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index bea7d3081..bda59989a 100755
--- a/setup.py
+++ b/setup.py
@@ -59,9 +59,10 @@ def svn_version():
def _minimal_ext_cmd(cmd):
# construct minimal environment
env = {}
- path = os.environ.get('PATH')
- if path is not None:
- env['PATH'] = path
+ for k in ['SYSTEMROOT', 'PATH']:
+ v = os.environ.get(k)
+ if v is not None:
+ env[k] = v
# LANGUAGE is used on win32
env['LANGUAGE'] = 'C'
env['LANG'] = 'C'