summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRalf Gommers <ralf.gommers@gmail.com>2019-05-07 11:00:50 +0200
committerRalf Gommers <ralf.gommers@gmail.com>2019-05-07 11:03:08 +0200
commit33415905e85c51c3348c1def9dfa306fbd358b5e (patch)
tree507dbdd0a40d258df0a763e6e2af403183c7f0de /setup.py
parent64b3e6791ff8cc51986b8dfbf5e63643304d2804 (diff)
downloadnumpy-33415905e85c51c3348c1def9dfa306fbd358b5e.tar.gz
MAINT: rename LICENSE_bundled.txt to LICENSES_bundled.txt
Finally seems to make the GitHub license detection mechanism happy
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 8315fbfcd..e88723820 100755
--- a/setup.py
+++ b/setup.py
@@ -187,17 +187,17 @@ def check_submodules():
class concat_license_files():
- """Merge LICENSE.txt and LICENSE_bundled.txt for sdist creation
+ """Merge LICENSE.txt and LICENSES_bundled.txt for sdist creation
Done this way to keep LICENSE.txt in repo as exact BSD 3-clause (see
gh-13447). This makes GitHub state correctly how NumPy is licensed.
"""
def __init__(self):
self.f1 = 'LICENSE.txt'
- self.f2 = 'LICENSE_bundled.txt'
+ self.f2 = 'LICENSES_bundled.txt'
def __enter__(self):
- """Concatenate files and remove LICENSE_bundled.txt"""
+ """Concatenate files and remove LICENSES_bundled.txt"""
with open(self.f1, 'r') as f1:
self.bsd_text = f1.read()