summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPearu Peterson <pearu.peterson@gmail.com>2006-03-31 09:38:29 +0000
committerPearu Peterson <pearu.peterson@gmail.com>2006-03-31 09:38:29 +0000
commit2a800cc944f0cbb2594a69cc1fbee3049ce6399b (patch)
treee4676c6c877dd300f00b1e58079b1959d79039c7 /setup.py
parentc31f2f845587db8101f697dc36286bd55d780ead (diff)
downloadnumpy-2a800cc944f0cbb2594a69cc1fbee3049ce6399b.tar.gz
Add svn revision number to version.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 5 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 04bd7a037..dd87837a8 100755
--- a/setup.py
+++ b/setup.py
@@ -54,10 +54,10 @@ def configuration(parent_package='',top_path=None):
config.add_subpackage('numpy')
-
- config.name = 'numpy'
- #config.dict_append(version=version)
- #print config.name,'version',config.version
+ config.name = 'numpy' # used in generated file names
+
+ from numpy.version import version
+ config.dict_append(version=version)
config.add_data_files(('numpy',['*.txt','COMPATIBILITY',
'scipy_compatibility']))
@@ -74,11 +74,7 @@ def setup_package():
sys.path.insert(0,local_path)
try:
-
- from numpy.version import version
- setup( configuration=configuration,
- version = version
- )
+ setup( configuration=configuration )
finally:
del sys.path[0]
os.chdir(old_path)