summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2013-07-11 12:08:49 -0600
committerCharles Harris <charlesr.harris@gmail.com>2013-07-11 12:43:18 -0600
commit28eadc0e31ca7aea5c679023d1e703856f45c879 (patch)
treead328cc92dddd315a574aa6b1c3baa948c8982ab /setup.py
parent49a587cd786242b05fcfd22d5cda961d733b68d4 (diff)
downloadnumpy-28eadc0e31ca7aea5c679023d1e703856f45c879.tar.gz
MAINT: Remove outdated version checks.
Because Numpy 1.8.0 will no longer supports Python versions < 2.6 we no longer need to check for that and can also remove the code that is specific to those earlier versions. To make this a bit safer, the toplevel setup.py file now contains a check of the Python version number and raises an error when run by an unsupported version.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6989a7a97..ae7f6f677 100755
--- a/setup.py
+++ b/setup.py
@@ -23,6 +23,9 @@ import sys
import re
import subprocess
+if sys.version_info[:2] < (2, 6) or (3, 0) <= sys.version_info[0:2] < (3, 2):
+ raise RuntimeError("Python version 2.6, 2.7 or >= 3.2 required.")
+
if sys.version_info[0] >= 3:
import builtins
else: