summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormattip <matti.picus@gmail.com>2019-05-01 22:53:54 -0400
committermattip <matti.picus@gmail.com>2019-05-01 22:53:54 -0400
commit1f1e8f94ea343084889bae2e9081c3fa3d581b65 (patch)
treed14ee70a8296403c67fcced338e4ed4bce86b40c /setup.py
parentf16c558fc3c3b57c4f2a93a80a778746ddd2f8ef (diff)
downloadnumpy-1f1e8f94ea343084889bae2e9081c3fa3d581b65.tar.gz
BUG: missing git raises an OSError
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index cd919bb23..1b7a60eac 100755
--- a/setup.py
+++ b/setup.py
@@ -79,7 +79,7 @@ def git_version():
try:
out = _minimal_ext_cmd(['git', 'rev-parse', 'HEAD'])
GIT_REVISION = out.strip().decode('ascii')
- except subprocess.SubprocessError:
+ except (subprocess.SubprocessError, OSError):
GIT_REVISION = "Unknown"
return GIT_REVISION