summaryrefslogtreecommitdiff
path: root/pavement.py
diff options
context:
space:
mode:
authorDavid Cournapeau <cournape@gmail.com>2009-03-29 12:05:22 +0000
committerDavid Cournapeau <cournape@gmail.com>2009-03-29 12:05:22 +0000
commit0b0dbdf45032ad170fbcb2068a95b34326a4a523 (patch)
tree396c369cecd1a5d71fb25b494a2ae1b2a152736d /pavement.py
parentd7f1ae929c99c71dee6a7a950937608ddbe92fce (diff)
downloadnumpy-0b0dbdf45032ad170fbcb2068a95b34326a4a523.tar.gz
Update paver script file doc + TODO.
Diffstat (limited to 'pavement.py')
-rw-r--r--pavement.py28
1 files changed, 25 insertions, 3 deletions
diff --git a/pavement.py b/pavement.py
index 6b6e6f7cb..482d20c05 100644
--- a/pavement.py
+++ b/pavement.py
@@ -1,4 +1,9 @@
"""
+This paver file is intented to help with the release process as much as
+possible. It relies on virtualenv to generate 'bootstrap' environments as
+independent from the user system as possible (e.g. to make sure the sphinx doc
+is built against the built numpy, not an installed one).
+
Building a fancy dmg from scratch
=================================
@@ -6,8 +11,13 @@ Clone the numpy-macosx-installer git repo from on github into the source tree
(numpy-macosx-installer should be in the same directory as setup.py). Then, do
as follows::
- paver clean clean_bootstrap
+ git clone git://github.com/cournape/macosx-numpy-installer
+ # remove build dir, and everything generated by previous paver calls
+ # (included generated installers). Use with care !
+ paver nuke
paver bootstrap && source boostrap/bin/activate
+ # Installing numpy is necessary to build the correct documentation (because
+ # of autodoc)
python setupegg.py install
paver dmg
@@ -17,8 +27,14 @@ Building a simple (no-superpack) windows installer from wine
It assumes that blas/lapack are in c:\local\lib inside drive_c. Build python
2.5 and python 2.6 installers.
- paver clean
- paver bdist_wininst
+ paver bdist_wininst_simple
+
+You will have to configure your wine python locations (WINE_PYS).
+
+The superpack requires all the atlas libraries for every arch to be installed
+(see SITECFG), and can then be built as follows::
+
+ paver bdist_superpack
Building changelog + notes
==========================
@@ -30,6 +46,12 @@ Assumes you have git and the binaries/tarballs in installers/::
This automatically put the checksum into NOTES.txt, and write the Changelog
which can be uploaded to sourceforge.
+
+TODO
+====
+ - the script is messy, lots of global variables
+ - make it more easily customizable (through command line args)
+ - missing targets: install & test, sdist test, debian packaging
"""
import os
import sys