summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrgommers <ralf.gommers@googlemail.com>2010-11-30 21:27:34 +0800
committerCharles Harris <charlesr.harris@gmail.com>2010-12-02 08:40:41 -0700
commita70de5c870aa9406ddd84fd98e3d32d4c006d18e (patch)
tree73a1ed482f9b3c6db11694aa337652ca256e61ca
parent9e8bf666147f32f45debf0e1cc2b960c4e1b7e61 (diff)
downloadnumpy-a70de5c870aa9406ddd84fd98e3d32d4c006d18e.tar.gz
BUG: complex.h is broken on Interix, so skip it. Closes ticket #1365.
-rw-r--r--numpy/core/setup.py14
1 files changed, 11 insertions, 3 deletions
diff --git a/numpy/core/setup.py b/numpy/core/setup.py
index b854e879f..c6ba3880a 100644
--- a/numpy/core/setup.py
+++ b/numpy/core/setup.py
@@ -169,6 +169,14 @@ def check_complex(config, mathlibs):
priv = []
pub = []
+ try:
+ if os.uname()[0] == "Interix":
+ warnings.warn("Disabling broken complex support. See #1365")
+ return priv, pub
+ except:
+ # os.uname not available on all platforms. blanket except ugly but safe
+ pass
+
# Check for complex support
st = config.check_header('complex.h')
if st:
@@ -425,7 +433,7 @@ def configuration(parent_package='',top_path=None):
PYTHON_HAS_UNICODE_WIDE = True
else:
PYTHON_HAS_UNICODE_WIDE = False
-
+
if ENABLE_SEPARATE_COMPILATION:
moredefs.append(('ENABLE_SEPARATE_COMPILATION', 1))
@@ -701,7 +709,7 @@ def configuration(parent_package='',top_path=None):
subst_dict)
config.add_npy_pkg_config("mlib.ini.in", "lib/npy-pkg-config",
subst_dict)
-
+
multiarray_deps = [
join('src', 'multiarray', 'arrayobject.h'),
join('src', 'multiarray', 'arraytypes.h'),
@@ -773,7 +781,7 @@ def configuration(parent_package='',top_path=None):
multiarray_deps.extend(multiarray_src)
multiarray_src = [join('src', 'multiarray', 'multiarraymodule_onefile.c')]
multiarray_src.append(generate_multiarray_templated_sources)
-
+
umath_deps.extend(umath_src)
umath_src = [join('src', 'umath', 'umathmodule_onefile.c')]
umath_src.append(generate_umath_templated_sources)