summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorJason Pellerin <jpellerin@gmail.com>2009-05-02 09:15:33 -0400
committerJason Pellerin <jpellerin@gmail.com>2009-05-02 09:15:33 -0400
commit07e741017ae93bad87869be11d984a851400eb9d (patch)
tree1b23406bdaa8fb873fa714a158c5d95096b079a3 /doc
parent03ed9ed69d3cc89cf2c79a530cb46a3f869d6a9c (diff)
downloadnose-07e741017ae93bad87869be11d984a851400eb9d.tar.gz
Tweakin the docs
Diffstat (limited to 'doc')
-rw-r--r--doc/.templates/indexsidebar.html6
-rw-r--r--doc/setuptools_integration.rst23
2 files changed, 21 insertions, 8 deletions
diff --git a/doc/.templates/indexsidebar.html b/doc/.templates/indexsidebar.html
index b90c0dd..71a076d 100644
--- a/doc/.templates/indexsidebar.html
+++ b/doc/.templates/indexsidebar.html
@@ -7,7 +7,11 @@
<h3>Install</h3>
<ul>
- <li><tt>easy_install nose=={{ version }}</tt></li>
+ <li>This release:<br/>
+ <tt>easy_install nose=={{ version }}</tt></li>
+ <li>Development (unstable):<br/>
+ <tt>easy_install nose==dev</tt>
+ </li>
</ul>
<h3>Community</h3>
diff --git a/doc/setuptools_integration.rst b/doc/setuptools_integration.rst
index f9f42e6..b886e76 100644
--- a/doc/setuptools_integration.rst
+++ b/doc/setuptools_integration.rst
@@ -1,6 +1,12 @@
Setuptools integration
======================
+.. warning :: Please note that when run under the setuptools test command,
+ many plugins will not be available, including the builtin
+ coverage and profiler plugins. If you want to access to all
+ available plugins, use the :doc:`nosetests <api/commands>`
+ command instead.
+
nose may be used with the setuptools_ test command. Simply specify
nose.collector as the test suite in your setup file::
@@ -17,13 +23,16 @@ When running under setuptools, you can configure nose settings via the
environment variables detailed in the nosetests script usage message,
or the setup.cfg, ~/.noserc or ~/.nose.cfg config files.
-Please note that when run under the setuptools test command, some plugins will
-not be available, including the builtin coverage, and profiler plugins.
-
-nose also includes its own setuptools command, ``nosetests``, that
-provides support for all plugins and command line options. See
-below for more information about the ``nosetests`` command.
+`nosetests` command
+-------------------
+
+nose also includes its own setuptools command, ``nosetests``, that provides
+support for all plugins and command line options. It works just like the
+``test`` command::
+
+ python setup.py nosetests
+
+See :doc:`api/commands` for more information about the ``nosetests`` command.
.. _setuptools: http://peak.telecommunity.com/DevCenter/setuptools
-.. automodule :: nose.commands