summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJarrod Millman <jarrod.millman@gmail.com>2019-10-07 13:28:00 -0700
committerJarrod Millman <jarrod.millman@gmail.com>2019-10-12 09:21:57 -0700
commit04bda295dc7a5b2208bf81a1c3d54d277c019a87 (patch)
treeeb3a519de9e757c029051fac3ac1a68ff121f607 /setup.py
parent9826de85241f649229086158dee3e397d48a8492 (diff)
downloadnetworkx-04bda295dc7a5b2208bf81a1c3d54d277c019a87.tar.gz
Have CIs use pytest
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 01eac1be..03bfd53a 100644
--- a/setup.py
+++ b/setup.py
@@ -124,11 +124,11 @@ package_data = {
install_requires = ['decorator>=4.3.0']
extras_require = {'all': ['numpy', 'scipy', 'pandas', 'matplotlib',
'pygraphviz', 'pydot', 'pyyaml', 'gdal', 'lxml',
- 'nose'],
+ 'pytest'],
'gdal': ['gdal'],
'lxml': ['lxml'],
'matplotlib': ['matplotlib'],
- 'nose': ['nose'],
+ 'pytest': ['pytest'],
'numpy': ['numpy'],
'pandas': ['pandas'],
'pydot': ['pydot'],
@@ -163,7 +163,5 @@ if __name__ == "__main__":
install_requires=install_requires,
extras_require=extras_require,
python_requires='>=3.5',
- test_suite='nose.collector',
- tests_require=['nose>=1.3.7'],
zip_safe=False
)