summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--.hgignore1
-rw-r--r--.travis.yml17
3 files changed, 19 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index e348038..15cdd0e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -22,6 +22,7 @@ pip-log.txt
# Unit test / coverage reports
.coverage
.tox
+.cache
#Translations
*.mo
diff --git a/.hgignore b/.hgignore
index d93555e..2607b61 100644
--- a/.hgignore
+++ b/.hgignore
@@ -24,6 +24,7 @@ pip-log.txt
# Unit test / coverage reports
.coverage
.tox
+.cache
#Translations
*.mo
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..80eae93
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,17 @@
+language: python
+
+python:
+ - 2.6
+ - 2.7
+ - 3.2
+ - 3.3
+ - 3.4
+ - pypy
+
+install:
+ # argparse is not in the 2.6 standard library
+ - if [[ $TRAVIS_PYTHON_VERSION == '2.6' ]]; then pip install argparse; fi
+
+script:
+ - python setup.py test
+ - python -m doctest README.rst