summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2018-05-11 23:47:54 -0700
committerSeth M Morton <seth.m.morton@gmail.com>2018-05-11 23:47:54 -0700
commitbc10c2783958138a0369b2241d2c0135198ceb0f (patch)
tree59f7584258eddc47ecff20ab084a0834d447de95 /tox.ini
parentcbe4b79c53a34160816b1e934c983dbddd46dd96 (diff)
downloadnatsort-bc10c2783958138a0369b2241d2c0135198ceb0f.tar.gz
Move all *requirements.txt to Pipfile.
The Pipfile only defines --dev packages. tox.ini and .travis.yml have been updated to support the new infrastructure.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini37
1 files changed, 14 insertions, 23 deletions
diff --git a/tox.ini b/tox.ini
index 31bdc1f..a1f360b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -14,38 +14,29 @@ envlist =
passenv =
WITH_OPTIONS
deps =
- -r{env:WITH_OPTIONS:}requirements.txt
- -rtesting-requirements.txt
- -rcpython-testing-requirements.txt
+ pipenv
+extras =
+ {env:WITH_OPTIONS:}
commands =
- {envpython} -m pytest --doctest-modules natsort
- {envpython} -m pytest README.rst docs/source/intro.rst docs/source/examples.rst docs/source/howitworks.rst
- {envpython} -m pytest --flakes --pep8 --cov natsort --cov-report term-missing --tb=short
+ pipenv install --dev --skip-lock
+ pytest --doctest-modules natsort
+ pytest README.rst docs/source/intro.rst docs/source/examples.rst docs/source/howitworks.rst
+ pytest --flakes --pep8 --cov {envsitepackagesdir}/natsort --cov-report term-missing --tb=short
[testenv:py26]
commands =
+ pipenv install --dev --skip-lock
{envpython} -m doctest README.rst docs/source/intro.rst docs/source/examples.rst
[testenv:py27]
commands =
- {envpython} -m pytest --doctest-modules natsort
- {envpython} -m pytest README.rst docs/source/intro.rst docs/source/examples.rst
- {envpython} -m pytest --flakes --pep8 --cov natsort --cov-report term-missing --tb=short
+ pipenv install --dev --skip-lock
+ pytest --doctest-modules natsort
+ pytest README.rst docs/source/intro.rst docs/source/examples.rst
+ pytest --flakes --pep8 --cov {envsitepackagesdir}/natsort --cov-report term-missing --tb=short
[testenv:pypy]
-deps =
- -rrequirements.txt
- -rtesting-requirements.txt
-commands =
- {[testenv:py27]commands}
-
-[testenv:jython]
-deps =
- pytest
- pytest-cache
-commands =
- {envpython} -m pytest --doctest-modules natsort
- {envpython} -m pytest README.rst docs/source/intro.rst docs/source/examples.rst
+commands = {[testenv:py27]commands}
# Build documentation.
[testenv:docs]
@@ -62,4 +53,4 @@ deps =
commands =
check-manifest
{envpython} setup.py sdist bdist_wheel
- {envpython} -m twine upload dist/*
+ twine upload dist/*