summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2017-04-30 23:03:49 -0700
committerSeth M Morton <seth.m.morton@gmail.com>2017-04-30 23:03:49 -0700
commit7bc490ddd2e38fd9bb5724708bcf8be8afe1e18f (patch)
tree57bba6a3c4a36e7e4bd6288f277fa4f857421a33 /tox.ini
parent8b25198de0bda041d95d9e3fe23343ad67a137c6 (diff)
downloadnatsort-7bc490ddd2e38fd9bb5724708bcf8be8afe1e18f.tar.gz
Added release code to tox.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini8
1 files changed, 8 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
index 5ecc4fa..a870411 100644
--- a/tox.ini
+++ b/tox.ini
@@ -8,6 +8,7 @@ envlist =
py26, py27, py33, py34, py35, py36, pypy
# Other valid evironments are:
# docs
+# release
[testenv]
passenv =
@@ -53,3 +54,10 @@ deps =
sphinx_rtd_theme
commands =
{envpython} setup.py build_sphinx
+
+[testenv:release]
+deps =
+ twine
+commands =
+ {envpython} setup.py sdist bdist_wheel
+ {envpython} -m twine upload dist/*