summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2019-11-19 12:30:57 -0800
committerSeth Morton <seth.m.morton@gmail.com>2019-11-19 13:59:44 -0800
commit4b8bc2c9a3df539fa4493ceb27266fe1c8d36d1a (patch)
tree4a49f322f78bc3291ad9e06d4e0af61377a04109 /tox.ini
parent6553121f320745c6cb31dc545ef2ef18ce437aff (diff)
downloadnatsort-4b8bc2c9a3df539fa4493ceb27266fe1c8d36d1a.tar.gz
Add clean and bump envs to tox.ini
These use re-written bump and clean auxillary scripts - these were once shell scripts but are now Python. Also, the README in dev/ has been updated.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini16
1 files changed, 16 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
index 698e9b9..594d0fd 100644
--- a/tox.ini
+++ b/tox.ini
@@ -9,6 +9,8 @@ envlist =
# Other valid evironments are:
# docs
# release
+# clean
+# bump
# Don't error out if a user hasn't installed all python versions.
skip_missing_interpreters =
@@ -57,6 +59,15 @@ commands =
{envpython} setup.py build_sphinx
skip_install = true
+# Bump version
+[testenv:bump]
+passenv =
+ HOME
+deps =
+ bump2version
+commands =
+ {envpython} dev/bump.py {posargs:}
+
# Release the code to PyPI
[testenv:release]
deps =
@@ -65,3 +76,8 @@ commands =
{envpython} setup.py sdist --format=gztar bdist_wheel
twine upload --skip-existing dist/*
skip_install = true
+
+# Clean up the working directory
+[testenv:clean]
+deps =
+commands = {envpython} dev/clean.py