summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2016-03-08 08:12:57 -0800
committerSeth M Morton <seth.m.morton@gmail.com>2016-03-08 08:12:57 -0800
commit12e1863763a11427f297dc080d6c56bc1471baf2 (patch)
tree828560dcd86dd0d7b3fdad9e7a58a56d281cbafc /tox.ini
parent1bd23192037a23ab7c7e847180d8009ff3b417e6 (diff)
downloadnatsort-12e1863763a11427f297dc080d6c56bc1471baf2.tar.gz
Updated tox and travis test runners.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini5
1 files changed, 4 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 56a7e8c..a7f7c36 100644
--- a/tox.ini
+++ b/tox.ini
@@ -8,7 +8,10 @@ envlist =
py26, py27, py33, py34, py35, pypy
[testenv]
-commands = {envpython} setup.py test
+commands =
+ {envpython} -m pytest --doctest-modules natsort
+ {envpython} -m pytest README.rst docs/source/intro.rst docs/source/examples.rst
+ {envpython} -m pytest --flakes --pep8
deps =
pytest
pytest-pep8