summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2017-04-30 17:24:37 -0700
committerSeth M Morton <seth.m.morton@gmail.com>2017-04-30 17:31:31 -0700
commit0b304af16822c857e20cbcbc9a4cc79d28816dcd (patch)
tree01b4cb4febd27838caa98fce10142fcf11e59ce4 /tox.ini
parentc8e03c5191f77eab2ceff910436d1cd1bc70054e (diff)
downloadnatsort-0b304af16822c857e20cbcbc9a4cc79d28816dcd.tar.gz
Updated tox.ini to use requirements.txt.
Part one in an effort to reduce the complexity of the development tools.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini56
1 files changed, 21 insertions, 35 deletions
diff --git a/tox.ini b/tox.ini
index 0aa4b70..cf785a7 100644
--- a/tox.ini
+++ b/tox.ini
@@ -6,62 +6,48 @@
[tox]
envlist =
py26, py27, py33, py34, py35, py36, pypy
+# Other valid evironments are:
+# docs
[testenv]
+deps =
+ -rrequirements.txt
+ -rtesting-requirements.txt
+ -rcpython-testing-requirements.txt
commands =
{envpython} -m pytest --doctest-modules natsort
{envpython} -m pytest README.rst docs/source/intro.rst docs/source/examples.rst docs/source/howitworks.rst
- {envpython} -m pytest
-deps =
- pytest
- pytest-cache
- pytest-faulthandler
- hypothesis
+ {envpython} -m pytest --flakes --pep8
[testenv:py26]
commands =
{envpython} -m doctest README.rst docs/source/intro.rst docs/source/examples.rst
-deps =
- pathlib
- argparse
[testenv:py27]
commands =
{envpython} -m pytest --doctest-modules natsort
{envpython} -m pytest README.rst docs/source/intro.rst docs/source/examples.rst
- {envpython} -m pytest
-deps =
- pytest
- pytest-cache
- pytest-faulthandler
- hypothesis
- mock
- pathlib
-
-[testenv:py33]
-deps =
- pytest
- pytest-cache
- pytest-faulthandler
- hypothesis
- pathlib
+ {envpython} -m pytest --flakes --pep8
[testenv:pypy]
+deps =
+ -rrequirements.txt
+ -rtesting-requirements.txt
commands =
- {envpython} -m pytest --doctest-modules natsort
- {envpython} -m pytest README.rst docs/source/intro.rst docs/source/examples.rst
- {envpython} -m pytest
+ {[testenv:py27]commands}
+
+[testenv:jython]
deps =
pytest
pytest-cache
- hypothesis
- mock
- pathlib
-
-[testenv:jython]
commands =
{envpython} -m pytest --doctest-modules natsort
{envpython} -m pytest README.rst docs/source/intro.rst docs/source/examples.rst
+
+# Build documentation.
+[testenv:docs]
deps =
- pytest
- pytest-cache
+ sphinx
+ sphinx_rtd_theme
+commands =
+ {envpython} setup.py build_sphinx